After upgrading to WebStorm 2022.3, JS or TS code is frequently not analyzed

Using Webstorm 2022.3, I started getting severe issues with the IDE not picking up code errors correctly, and also not understand when issues are fixed. So for example, the ID will redline some piece of code that is completely irrelevant and show some weird error message, or the IDE will not auto-complete and suggest functions to import, or it will not show syntax color highlighting, make symbols clickable, show strikethrough on deprecated calls etc etc etc.

This has happened a few times in the past using older versions, but usually it has been resolved by 1) restarting TypeScript service or 2) restarting project and/or WebStorm. But now I've tried everything. Some files just end up in this state after any change made. I have a key shortcut for "compile project" which when clicked sometimes removes some of the errors, but sometimes red lines are left on code which is perfectly valid, with error messages relating to something completely different such as "expression expected" or whatever.

Since I don't have a specific project to share etc, to begin with I'm asking for tips on how to debug this further. What could I restart, where could I find logs etc?

I've update TypeScript to 4.8.4 in the project settings, I've restarted the typescript service, I've disabled and re-enabled Node.JS code assistance, I've verified that my Node (14) installation is valid. I've cleaned my project, deleted .tsbuildinfo files, reinstalled node_modules, ...

Attached is a short video where I'm writing code which is valid, then invalid, then valid again. Sometimes it just seems indexing and/or compiling is extremely slow, but sometimes it just doesn't happen at all:

Upload id: 2022_10_13_G5e8MAgqzeEmMNFQHCWnxn (file: Screen Recording 2022-10-13 at



does it happen with the errors coming from the Typescript language service only? Please try disabling it in Preferences | Languages & Frameworks | TypeScript and then invalidate caches (File > Invalidate caches, Invalidate and restart) - will error highlighting work any faster?


I have the same issue, it's very slow and it picks up errors incorrectly



I have the exact same issue with Webstorm 2022.3


I'm having the same issue. Upgraded to WebStorm 2022.3, TS stops analyzing. I've tried invalidating caches, reinstalling node_modules, clearing built artifacts, etc. Error detection doesn't work at all.


Please sign in to leave a comment.