Cannot set up a python SDK at Python 3.10.8 in window 11 22H2

1. Setting - Python interpreter - add local interpreter

Get error

Invalid Python SDK

Cannot set up a python SDK at Python 3.10.8 The SDK seems invalid.


2. New project - New Virtualenv environment - Base interpreter local python 3.10.8

and all of another doing which create new virtualenv

Get error

Failed to create a virtual environment


i already doing

reinstalled pycharm, python, window 11(22h2)

use different python version.

File - Invalidate Caches

File - Setting - Editor - File Encodings - "Project Encoding", "Default encoding for Properties Files" change to UTF-8


In cmd, python working properly

here is log

JetBrains Upload Service.

Upload id: 2022_10_15_of1zxPvq1JpoUFX6n7J6Rm (file: idea.log)

Google drive.



I've been suffering from this problem for a few days and I'm going to lose my mind. plz somebody help me...


I also met this issue when I tried to use PyCharm 2022.2.3.

When I used PyCharm 2022.2.2, with the same conda env, not met this issue.

My OS is Windows 11 22H2. The python version of my conda env is 3.10.6.


thx it solved when downgrade 2022.2.2. i really appreciate your help.


I still get this issue using 2022.3.1 and Python SDK 3.1,  even after setting Default Encoding to UTF-8. Should i downgrade to 2022.2.2 ?


I had this issue today/yesterday night, was getting invalid python SDK. Re-installed Python, followed by PyCharm. Turn out all I had to do was run PyCharm in Admin Mode, now it works like… well… a charm.


Please sign in to leave a comment.