Internal/Local ports 63342, 6942

Hello,

I noticed that PHPStorm opens 2 local ports 63342, 6942 on my machine while PHPStorm is open. Is there a way to disable the services behind those ports?

I read that PHPStorm has a built-in webserver running on port 63342. But I couldn't find way to disable it anywhere. The other port seems to be internal.

Since I see open ports as a security risk, especially when not needed, I'd rather disable them both.

P.S. I'm running the evaluation program right now, if that makes any difference.

- Dennis

6 comments
Comment actions Permalink

Hi there,

This is all As Far As I Know:

1. One of them (should be 6942) is used for internal communications (inter process coms) -- used by many complex apps. The IDE will fail to start if it cannot use such a port (e.g. when they are all busy or reserved by the OS -- check https://youtrack.jetbrains.com/issue/IDEA-238995 for example).

2. The other one (63342) is indeed used by a built-in web server. You can change the port number or disable accepting connections from other computers there: "Settings (Preferences on macOS) | Build, Execution, Deployment | Debugger" -- https://www.jetbrains.com/help/phpstorm/2022.2/settings-debugger.html#833f8720 . But you cannot disable it (at very least I do not remember seeing such options anywhere, could not see anything related in the Registry either).

One of those ports is also used by Git Integration etc. (e.g. from this comment).

it's not a debugger, this port is used by the IDE for internal communications, built-in web server, Git integration etc. and should only be changed in some rare cases where user clearly know how it works/what that is for. Default value is 63342

0
Comment actions Permalink

Then this is the end for me and PHPStorm. Sadly. Access from other apps could allow access to PHPStorm. One example are WebRTC connections. Hence an attacker could get access to my data, and my unreleased projects.

Thanks for the clarification, Andriy.

0
Comment actions Permalink

@Dennis Bitsch

As I have mentioned: the above just my own knowledge. And I'm not JetBrains employee.

I would suggest to wait for the official reply here from one of the JetBrains folks or might be even better: submit the Support Ticket (either from "PhpStorm | Help | Contact Support..." or here by licking on "Submit a Request" link at the top of the page). Here on Forums you may wait 1, 2 sometimes 3 days to get a reply while the Support Ticket can be assigned to the right person faster.

0
Comment actions Permalink

Starting version 2022.3 you can add -Didea.builtin.server.disabled=true to custom VM options (Help > Edit Custom VM Options) to disable it. This is an experimental feature and it still being tested.

0
Comment actions Permalink

Hi Dmitry,

thanks for the quick reply. I can confirm that this actually works. Port 63342 is closed now.

I'd love to see a similar approach for that port also in the future.

0
Comment actions Permalink

Without an opened port 6942 (or any available one of 50 ports between 6942 and 6991, to be precise) IDE won't start, sadly. So this isn't something that going to be changed anytime soon.

0

Please sign in to leave a comment.