SSL connection error with RDS database


I've tried to connect to an PostgreSQL database hosted on Amazon RDS with my Mac (OS v12.6 Monterey) using DataGrip but I get the following error:

DBMS:   Case sensitivity: plain=mixed, delimited=exact Driver: (ver. , JDBC) Effective version: PostgreSQL (ver. 0.0)
 SSL error: Connection reset

I've tried connecting via the command line with the following:

psql -h <rds_host> -U <username> <database_name>

I also downloaded TablePlus and was able to successfully connect to the same DB with that tool as well.

I understand that the error message quoted above is telling me there is an SSL error, but I'm guessing that's something being handled with TablePlus and needs to be explicitly set with DataGrip's SSH/SSL menu?  I was exploring the menu but unsure where the certs would be.

Any assistance would be greatly appreciated.

1 comment


Please collect the IDE logs via Help | Collect Logs and Diagnostic Data, upload them to and provide its ID.


Please sign in to leave a comment.