Xdebug is Automatically resolving breakpoints

Hi community!

I have a problem with my local xdebug.  I am on an iMac running Monterey 12.6 and I have a docker container running ubuntu 20.04 with php 7.4 and xdebug 3.  I have xdebug set up and when I insert a breakpoint in PhpStorm, I can see that it picks it up.  What is bizarre though, is that recently it's started to automatically resolve the breakpoint.  I see xdebug stop at the breakpoint for a split second, flash green to show it's stopped, then flash back to red and the xdebug session is done.  If I put in multiple breakpoints only the first one is resolved, and the rest ignored.

I've double checked I have no sticky keys, and removed all keymaps for "Resume Program" just in case. I've tried rolling back both PhpStorm, and Docker.  I've tried restarting.  I haven't tried rolling back OS though as I want that to be an absolute last resort.

My xdebug.ini settings:


Anyone got a similar problem?


Yes, Xdebug log does not have an exit -- last entry is evaluating some statement and no response to that (for whatever reason).

Makes sense to also enable extra logging for PHP Debugger on PhpStorm end (to see what PhpStorm thinks of that): https://www.jetbrains.com/help/phpstorm/troubleshooting-php-debugging.html#5d594e8f

P.S. Do you have any watches (looks like you do to me)? If you do -- please clear them all and try again (check debugger panel options, you should be able to display them separately and not combined in a single list/panel).


If those links don't work, these are the files I uploaded to Jetbrains support:

JetBrains support will be able to help you then. I do not work for JetBrains and cannot see those links.


Hi there,

Just a thought: maybe it's crashing. I suggest you check Xdebug log to see how it ends.


P.S. What is your IDE version? if it's 2022.2, will disabling "Settings (Preferences on macOS) | PHP | Debug | Enable '__toString' object view" make things any different (if it's enabled, ofc)?


Hi Andriy!

I had a look at the logs.  The only error is a notify warning about a deprecated function.  I've commented it out and also turned off the setting you suggested, but unfortunately it's still happening.  I stopped and started the xdebug session too just to be sure. Such a strange issue!

Best wishes,

EDIT: IDE version is 2022.2.3


I meant: how Xdebug log ends -- do you see a clean exit from the debug session there?

I suggest you clear Xdebug log, try to debug some simple script that shows the issue and then share the log.

P.S. Having a small video/screencast illustrating the issue might be helpful as well (as it may show some nuance that otherwise can be ignored).


Hi Andriy,

I've checked the logs and it looks like it's not ending clean.  I'm not seeing anything indicating a finish to the session.

Here's the log: https://drive.google.com/file/d/1OCQj4pEN2VIGnsXR6jEvruDDLsvA4LDx/view?usp=sharing

Here's a video: https://youtu.be/tkqU77G4URU

Let me know if any of those links don't work. I'm unsure of how to upload stuff like this to the forums as there's no option for anything but links and images in the wysiwyg.   Hopefully I'm not breaking any sort of community guidelines.

Best wishes,


Hi Andriy,

I removed the watches and it's working again! I honestly am unsure how those watches got there but the problem was definitely within them.

Thank you so much for your help!

Best wishes,


Please sign in to leave a comment.