10 comments
Comment actions Permalink

You need to remove the PHPSTORM_VM_OPTIONS environment variable. In most cases, "unset PHPSTORM_VM_OPTIONS" command should do the trick.

0
Comment actions Permalink

 

I don't have this environment variable

0
Comment actions Permalink

Have you tried to restart the OS after the 'unset' command? Also, I would recommend removing other *_VM_OPTIONS variables (like IDEA_VM_OPTIONS).

0
Comment actions Permalink

thank you,

Delete it and it's ok

0
Comment actions Permalink

Now I'm booting through phpstorm.sh, but I can't use phpstorm.app to boot

 

 

 

0
Comment actions Permalink

Thanks for the update, the situation looks better now.
Please also check if you have any traces on the _VM_OPTIONS variables in these locations as well:

~/.profile
~/.zshrc
~/Library/LaunchAgents/jetbrains.vmoptions.plist
~/Library/LaunchAgents/environment.plist 
~/.bash_profile
~/.bashrc

0
Comment actions Permalink

 

 

I don't see much about that 

What should I do?

0
Comment actions Permalink

Are you still there?

0
Comment actions Permalink

Sorry for the late response.

There must be an environment var still sits somewhere and prevents IDE from being launched normally. Here is a similar ticket (check relatives as well):
https://youtrack.jetbrains.com/issue/IDEA-282172/macOS-launcher-crashes-on-an-attempt-to-show-an-alert-NSWindow-drag-regions-should-only-be-invalidated-on-the-Main-Thread

Please try to remove the "jetbrains.vmoptions.plist" file (or move it somewhere else for now) and restart the OS, would it help?

0
Comment actions Permalink

jetbrains.vmoptions.plist。  After I deleted it, it started working fine,thank you

1

Please sign in to leave a comment.