Window is rendered incorrectly (rotated 90 degrees)

Something weird is going on when pycharm is on the external screen.
The window gets rendered incorrectly – it is partially black with a fraction of the code area rotated 90 degrees. 

Even more weirdly, whenever I take a screenshot, it looks okay :) (meaning it gets captured as if there are no issues).

I am using Mac OS Ventura 13.0 (22A380) 

12 comments
Comment actions Permalink

It looks like an image from the external screen is overlayed over main screen? Which software do you use to access the external screen? Are other apps shown correctly?

0
Comment actions Permalink

Were you able to solve this issue?

0
Comment actions Permalink

I am experiencing the same issue when intellij is in fullscreen and the screen goes to sleep. After wakeup intellij is rotated 90 degrees. Restarting intellij doesn't solve the issue, only restarting the mac helps. Started happening after the macos ventura uodate together with this bug as well: https://youtrack.jetbrains.com/issue/JBR-4959/macOS-Ventura-Screen-flickering-after-OS-update-when-IDE-is-full-screen?s=macOS-Ventura-Screen-flickering-after-updating

0
Comment actions Permalink

Yeah, I noticed it stopped after restarting the macbook

0
Comment actions Permalink

After the latest update the flickering has stopped and not the window isn't rotated, it just turns black. Restoring and then going full screen again solves the issue for me now.

0
Comment actions Permalink
Could you please submit a bug report to https://youtrack.jetbrains.com ?
0
Comment actions Permalink

I take my previous comment back, I started to see the issues again. But the flickering I mentioned before seems to happen a lot less now. The window rotating still happens.

0
Comment actions Permalink
Could you please check if the issue still persists in 2022.3 EAP? https://www.jetbrains.com/pycharm/nextversion/

Also, try adding `-Dsun.java2d.metal=false` VM option and check if it helps (https://intellij-support.jetbrains.com/hc/en-us/articles/206544869)
0
Comment actions Permalink

I was able to workaround this issue by setting "Automatically hide and show the menu bar" to "Never" in system settings.

More info: I've also been experiencing this issue since Ventura. I noticed it only happens when Pycharm is in full screen and when I moused up to the menu bar it would dynamically "correct" itself. Based on this I tried the above workaround. Not using full screen also worked.

1
Comment actions Permalink

Pbellora That solved the issue for me as well! When in full screen the IDE behaves weird due to the menu bar hiding itself and then the IDE screen rotates 90 degrees until I move mouse around and it flickers between rotated and not rotated. Definitely a bug with menu bar hiding itself in Mac

0
Comment actions Permalink

I also have the same issue with goland after updating mac (M1) to ventura 13.1 and updating goland to 2022.3.1. For me two workarounds seem to help:

  • Automatically hide and show the menu bar in system settings as Pbellora suggested
  • Also if I have multiple project windows open, this issue doesn't occur (at least for me), so only seems to happen when only a single project is open
0

Please sign in to leave a comment.