Why doesn't my symlinkto a folder appear in pycharm's remote host list in the IDE?

All the sym links seem right in the servers & I've had symlinks to folders work before in pycharm's remote host. So I am wondering what I did wrong. The one I want to appear in the remote host list in pycharm is `data`:
```
lrwxr-xr-x 1 brando9 users   26 Nov  9 11:41 data -> /dfs/scratch0/brando9/data
```
It seems right on the servers:
```
(metalearning_gpu) brando9/afs/cs.stanford.edu/u/brando9 $ ls -lah
total 507K
drwxrwxrwx 7 brando9 users 2.0K Nov  9 11:41 .
drwxr-xr-x 2 root    users 476K Nov  9 11:46 ..
-rw------- 1 brando9 users 3.5K Nov  9 11:30 .bash_history
lrwxr-xr-x 1 brando9 users   29 Jun 20 08:41 .bash_logout -> /afs/cs/etc/skel/.bash_logout
lrwxr-xr-x 1 brando9 users   30 Jun 20 08:41 .bash_profile -> /afs/cs/etc/skel/.bash_profile
lrwxr-xr-x 1 brando9 users   24 Jun 20 08:41 .bashrc -> /afs/cs/etc/skel/.bashrc
-rw-r--r-- 1 brando9 users 1.7K Nov  9 11:34 .bashrc.user
lrwxr-xr-x 1 brando9 users   23 Jun 20 08:41 .cshrc -> /afs/cs/etc/skel/.cshrc
lrwxr-xr-x 1 brando9 users   26 Nov  9 11:41 data -> /dfs/scratch0/brando9/data
drwxr-xr-x 5 brando9 users 2.0K Nov  9 11:35 diversity-for-predictive-success-of-meta-learning
drwxr-xr-x 6 brando9 users 2.0K Nov  9 11:39 iit-term-synthesis
lrwxr-xr-x 1 brando9 users   23 Jun 20 08:41 .kshrc -> /afs/cs/etc/skel/.kshrc
lrwxr-xr-x 1 brando9 users   23 Jun 20 08:41 .login -> /afs/cs/etc/skel/.login
lrwxr-xr-x 1 brando9 users   24 Jun 20 08:41 .logout -> /afs/cs/etc/skel/.logout
lrwxr-xr-x 1 brando9 users   25 Jun 20 08:41 .profile -> /afs/cs/etc/skel/.profile
drwxr-xr-x 7 brando9 users 2.0K Nov  9 11:38 pycoq
drwx------ 2 brando9 users 2.0K Nov  9 11:20 .ssh
lrwxr-xr-x 1 brando9 users   24 Jun 20 08:41 .tcshrc -> /afs/cs/etc/skel/.tcshrc
drwxr-xr-x 7 brando9 users 2.0K Nov  9 11:44 ultimate-utils
-rw------- 1 brando9 users 1.5K Nov  8 12:20 .viminfo
lrwxr-xr-x 1 brando9 users   23 Jun 20 08:41 .zshrc -> /afs/cs/etc/skel/.zshrc
```
but look at the pycharm remote host IDE list:

[![enter image description here][1]][1]

Anyone knows what the issue might be?

My deployment config is as follows:

[![enter image description here][2]][2]


  [1]: https://i.stack.imgur.com/GpAOd.png
  [2]: https://i.stack.imgur.com/La1d8.png

 

https://stackoverflow.com/questions/74380629/why-doesnt-my-symlinkto-a-folder-appear-in-pycharms-remote-host-list-in-the-id

1 comment
Comment actions Permalink

We're checking this with the user in the support ticket. We have to check the logs first.

0

Please sign in to leave a comment.