IDE cant open, re-installing does not work

Answered

So I was looking around for some async solutions and I found one on github, https://github.com/electronicarts/ea-async

I follow the setup instructions for maven. Only to realize it didn't work (I didn't realize the last time it was worked on was a few years ago). So I remove it and I use a different library, I finish that section of code and I close the IDE.

Next time I try to open it to work on the code it doesn't open. I try to launch the idea.bat from bin and it says:

Error opening zip file or JAR manifest missing : ea-async-1.2.3.jar

Error occurred during initialization of VM

agent library failed to init: instrument

I don't have much knowledge of agents and I've been trying to remedy this for about 2 days now. I went back and re-checked my project files for references to the library. I re-installed the IDE a few times now. Nothing seem to work. I don't know what keeps referencing it. Does anyone know how to resolve this? I am not really familiar with this issue.

2 comments
Comment actions Permalink

Sorry for the delayed response, we didn't get a notification for this post due to a bug in the system.

It looks like you have `-javaagent:ea-async-1.2.3.jar` somewhere in the IDE VM options. See https://intellij-support.jetbrains.com/hc/en-us/articles/206544869.

You should be able to locate the file in the config directory of the IDE and edit it.

If nothing helps, see https://intellij-support.jetbrains.com/hc/en-us/articles/360007568559.

0
Comment actions Permalink

I appreciate the response Serge! A helpful support engineer named Ethan was able to get me through it. I had removed the argument in the main bin but it still persisted in the AppData roaming folder. As far as I know, I believe this link Ethan sent, and the one you provided, explains what had happened: 

Please note that custom .vmoptions file created using 'Edit Custom VM Options' action has the priority over the original file in the bin directory.

 

However I was unaware at first it was using a custom options file

0

Please sign in to leave a comment.