Remote SSH Interpreter: Nothing's working since latest update

PyCharm 2022.2.4 (Professional Edition)

I've recently updated to the latest version of the Professional Edition and since then everything has gone south. The issues are:

  • PyCharm opens local (?) cached files during debugging
  • Killing a process is not working (it takes half a minute until anything happens)


I've created a remote interpreter and pointed it to the interpreter of choice:

This interpreter is set as default for the project.

Here's the connection/mapping for the deployment:



As mentioned, as PyCHarm hits the breakpoint, it opens locally cached files in ~/Library/Caches/Jetbrains/Pycharm2022.2/remote_sources/<etc> (remote_sources ?!). This is incredibly annoying because this means I cannot edit the code and it opens up another unnecessary tab each time the code hits a different file.

The other issue is that stopping/killing the process does not work or takes ages. Clicking the stop button just turns it into the skull-icon after which I have to wait half a minute for something to happen. 

What I've tried

I have repeatedly re-created the entire setup after deleting the SSH interpreter and deployment configuration etc. I have restarted PyCharm and also tried to invalidate all cached files but nothing worked.


What is going on here and how can I fix this?

1 comment
Comment actions Permalink

Apparently this is a bug in the latest version (see [1]).

I downgraded to 2022.1.4 which resolves the problem for now.




Please sign in to leave a comment.