IntelliJ Ultimate 2022.3 - Make code links open in new tab?

Answered

Just upgraded to 2022.3, and now when I CTRL+LClick on a function, or right click a function name to jump to that code that is in another file, it no longer opens in a new tab. How do I make it open in a new tab? I can't find a setting for this, searching for "Tab".

Any advice would be greatly appreciated, especially since the back button is no longer part of the UI.

9 comments
Comment actions Permalink

Settings (Preferences on macOS) | Advanced Settings | Open declaration source in the same tab.

1
Comment actions Permalink

Thanks for the response. This may be a bug then, I tried with that setting checked and unchecked, and it is still opening in the same tab regardless.

0
Comment actions Permalink

Please see this comment: https://youtrack.jetbrains.com/issue/IDEA-306615/Open-declaration-source-in-the-same-file-option-doesnt-work#focus=Comments-27-6653430.0-0.

This behavior is controlled by a different option that takes precedence in this case: "When navigating to a file, prefer selecting existing tab in inactive split pane"

0
Comment actions Permalink

I tried with that option checked and unchecked as well, no difference. There is no split pane involved.

I am also noticing that this is happening in PHP code, but not in Python code. Is it possible the PHP plugin for IntelliJ is ignoring the setting?

Python and PHP plugins are version 223.7571.182.

0
Comment actions Permalink

 

Disable "Enable Preview Tab" setting in project explorer.

8
Comment actions Permalink

it is a new tab interactive logic.

if you use CTRL+ LFETCLICK jump to another file,you will find that it open in current tab and the filename is in italics.  When you do any editing operations in the file or DUBBO-CLICK current tab, filename will in Roman type

if the  filename is in italics type, CTRL + LECFCLIICK will open in current tab.

if the filename is in roman type, CTRL + LECFCLIICK will open in another tab.

0
Comment actions Permalink

Ok, so, working as intended, I guess. I turned off the Preview Tab feature and that solved it.

It didn't seem that the filename was always italicized though. Wil recheck that, might be a whole other part of this.

Thanks. 

0

Please sign in to leave a comment.