Problem with debugging libraries



I'm audiodeveloper. After updating Clion to version 2022.3 I have a problems
with debugging VST plugins. In debug configuration parameter Executable targeted to start host application (REAPER in my case). However, after starting debug session, host app started with no problems, but breakpoints doesn't hit. Clion writes that 'Breakpoints will not currently be hit... '

Everything worked well before. Any ideas how to fix this problem? Thanks



Sorry for the delay.

If the issue is still relevant, please try using CLion 2023.1 EAP. If the issue is reproducible in it, please enable debugger logging as described here, reproduce the issue and send the resulting idea.log file (Help | Show Log in ...) to clion-support at Do not forget to disable debug logging after that. Note that logs might contain private user's information (like file paths and names). 


Hi, Anna! Thanks for your reply!
I solved this problem. Actually, by removing conan integration from my project. I don't know, why conan causes this problem, but removing all conan cmake files from my project solves this issue. Currently I'm switched to using vcpkg, and all works fine for me.


Please sign in to leave a comment.