"Process finished with exit code 127" & "Cannot open shared object file: No such file or directory" [SOLVED]

Completed

Possible solution:

https://geant4-forum.web.cern.ch/t/running-geant4-with-clion/9720/2

 

Hello!

I'm trying to run GEANT4 project via CLION. It worked the first time, but suddenly just stopped sadly.

To read more about GEANT4: https://geant4.web.cern.ch/

I'm trying to run an executable after building the project with the GEANT4 libraries, yet I receive the following:

"/home/jordan/msc/software/geant4/geant4-work/g4test/cmake-build-debug/sim: error while loading shared libraries: libG4graphics_reps.so: cannot open shared object file: No such file or directory

Process finished with exit code 127"

I made sure that libG4graphics_reps.so does exist:

These are my environment variables:

PATH=@bindir@:/home/jordan/geant4_workdir/bin/Linux-g++:/home/jordan/msc/software/geant4/geant4-10.7.3-install/bin:/home/jordan/msc/software/geant4/geant4-10.7.3-install/bin:/home/jordan/msc/software/geant4/geant4-10.7.3-install/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/snap/bin

The project builds just fine, and i can run the executable from the bash cli (and the project does update to changes), but when I press "run" in clion I get the mentioned errors.

Is there anything else that can be done?

1 comment
Comment actions Permalink

I think I've found a solution, consult the following link:

https://geant4-forum.web.cern.ch/t/running-geant4-with-clion/9720/2

 

0

Please sign in to leave a comment.