Key functionalities in Pycharm are not working as they should

Since few days I have noticed that my IDE is not acting as it should. I have no idea what can be the cause of it. I don't remeber doing something different than usual. Some key problems I'm facing:

  • when using find usage in files no results are shown (even though I now that it is present in project and previously it was working)
  • IDE is not suggesting anything when typing
  • when using ctrl+b on some code snippet nothing is happening (previously I could jump to the usage of it) -analyzing some file is always in progress and does not show any results

Thinks I tried, but didn't work:

  • invalidate caches and restart
  • unistalled pycharm and installed it again (previously I have installed pycharm using snap, now I'm using toolbox)
  • delete project and clone it again with new virtualenev
  • also tried rescaning indexes, but it takes forever and even after leaving it over a night it is not finished

If it is important I have my pycharm installed on ubuntu inside Virtual Machine. Do you have any idea how else could I repair it?



Please upload  logs folder zipped from ***Help | Collect logs and Diagnostic Data***  to the FTP and please let me know the filename. 


Upload id: 2022_12_22_3xfBB4VhJnzyZFk9tTGBS7 (file:


Please try  Help -> Edit Custom Properties, then added caches.indexerThreadsCount=1.


Let me know how it goes. 


Yay, it helped. Thanks a lot. 


hello Antonina,

your suggestion is really appreciable worked for us


I'm having the same problem where find usages is not finding known usages, but Find in Files (All Places or In Project) finds 25. I've done the thread setting described above, and gone through the entire “Repair IDE” process, (checked all the boxes on the clear caches etc. dialog), waited for it to re-index everything, and it still says there are no usages.


PyCharm 2023.3.1 (Professional Edition)
Build #PY-233.11799.298, built on December 11, 2023

Runtime version: 17.0.9+7-b1087.7 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 14.2
GC: G1 Young Generation, G1 Old Generation
Memory: 16384M
Cores: 12
Metal Rendering is ON
Non-Bundled Plugins:
 eu.osimowicz.plugins.intellij.CodeBlocksSorter (0.1.2)
 lermitage.intellij.extratci (1.29.0)
 some.awesome (1.14)
 org.intellij.plugins.hcl (233.11799.172)
 com.github.copilot (
 com.mroche.JsonHelper (1.3.0)
 org.jraf.intellijplugin.nyantray (1.2.0)
 com.intellij.ideolog (
 String Manipulation (9.12.0)
 com.github.crazybene.crazycolortheme (1.0.3)
 com.intellij.mermaid (0.0.18+IJ.232)
 me.lensvol.blackconnect (0.6.1)
 com.github.camork.fileExpander (2.3)
 net.seesharpsoft.intellij.plugins.csv (3.2.3-233)
 dev.blachut.svelte.lang (233.11799.172)
 izhangzhihao.rainbow.brackets (2023.3.9-233) (0.12.0)
 ru.adelf.idea.dotenv (2023.3) (1.29.0)
 com.intellij.bigdatatools.core (233.11799.300)
 com.intellij.bigdatatools.binary.files (233.11799.267)
 com.intellij.bigdatatools.rfs (233.11799.300)
 com.github.dinbtechit.vscodetheme (1.10.7)
 zielu.gittoolbox (500.1.2+222)
 mobi.hsz.idea.gitignore (4.5.2)
 pw.mcclure.djaneiro.pycharm (1.2)
 com.github.hugohomesquita.htmxjetbrains (0.0.9)

Hey @Isaac Csandl,
Please create an issue on YouTrack so we can investigate this problem properly, or contact us directly with Help | Contact Support.

Please sign in to leave a comment.