Cannot configure Ruby Interpreter with RubyMine


I am trying to configure RubyMine to point to a Ruby interpreter on my mac, but it doesn't seem to work. I select the interpreter in Ruby SDK and Gems, but it does not save my selection. Anyone know why?

When i go back to the editor it still says "No Ruby Interpreter configured for this project". I then go back to the settings and neither interpreter has been selected. Its super frustrating.


Hello Peter,

Could you please specify your RubyMine's version.

That problem sometimes occurs when some project's related config files are corrupted, so could you please try the following:

1. Close the project in question in IDE
2. Remove .idea folder from its root
3. Reopen the project and try setting SDK again

Please let me know how it goes.



Clearing the .idea folder seemed to work. Thank you!


I am unable to select any path that works.  Using rvm.

IDE is unable to figure out what ruby versions are installed and choosing a specific ruby version does not work either.  I can choose my ~/.rvm directory or ~/.rvm/rubies/ruby-3.2.2 and neither has any effect.

Thank you for contacting support. We have seen all the questions related to this issue with RVM. All answers and future conversations will be collected in the first created ticket. 

Have a lovely day!

Best regards,
Karina Mokleva,
The RubyMine team

Please sign in to leave a comment.