My GWT project won't build after moving to new machine


Hi I urgently need help with making my project build. 

It's a maven based GWT project, works fine on all old computers, but now I had to move to a new one. I have copied my project structure from old machine (contains all IntelliJ files)

On new machine I get a maven build error:

failed for


from the specified remote repositories:

  Maven (, releases=true, snapshots=false), (, releases=true, snapshots=false),

  codehaus (, releases=true, snapshots=true), (, releases=true, snapshots=true), (, releases=true, snapshots=false),

  com.springsource.repository.bundles.release (, releases=true, snapshots=true),

  com.springsource.repository.bundles.external (, releases=true, snapshots=true),

  org.springframework.maven.milestone (, releases=true, snapshots=true), (, releases=true, snapshots=true),

  central (, releases=true, snapshots=false)

Path to dependency: 

1) temp:temp:pom:666

at org.apache.maven.repository.legacy.resolver.DefaultLegacyArtifactCollector.recurse(

at org.apache.maven.repository.legacy.resolver.DefaultLegacyArtifactCollector.collect(

This is strange because 1. I have *NO* reference to org.gwtproject anywhere in my pom files and 2. my project builds fine from the command prompt
The error message is also strange to me, what is "temp:temp:pom" ? Is it some temporary in-memory thing?
I have tried:
clearing all caches etc.
reinstalling intellij
trying with the last version (2022.2)
going through Library and deleting all JetBrains related data I could find.
I am at a loss, WHERE does the org.gwtproject that IntelliJ references come from.
I really need help since I can't run inside IntelliJ right now.
Comment actions Permalink

Let's first try to understand if the is related to IntelliJ IDEA or not. Please check - does it build by Maven form the command line? What output do you get in this case?

Comment actions Permalink

Hey, as I write in my post it builds fine from the prompt and we can run the compiled wars containing the GWT-compiled site code in tomcat, just like before. All the stuff ends up in the same place in .m2 as far as I can see. This is how we have to work right now since nothing works inside IntelliJ.

I have run the find command recursively on all xml files in the project dir, the "gwtproject" string is nowhere, so WHERE does IntelliJ get it from? As I write above I have tried clearing all IntelliJ dirs, reinstalling etc. What is the "temp:temp:pom" that the error log refers to?


EDIT - one more thing - on my new machine, the project also gets source level 1.5 even though I have it defined as 1.8 in the maven plugin definition. It never did that before either. To clarify - if I "open module settings", the project has 1.8 and every module has 1.8, but when I try to rebuild the project, it breaks with an error that the diamond operator is not available with source level 1.5...

Comment actions Permalink

Do you use maven-gwt-plugin? It looks like IDE tries to find the GWT SDK on build and fails.

>on my new machine, the project also gets source level 1.5 even though I have it defined as 1.8

Where do you have it defined? Do you have aggregator Maven projects? 

Would it be possible to get a sample project to check? For uploading you can use

Comment actions Permalink

Hi Andrey, some comments:

1. GWT is there since I can build in maven from the command prompt and run it in tomcat locally. It compiles GWT fine there.

2. I have source set to 1,8 in the maven wrapper config in the POM.

3. The problem with the org.gwtproject in the stack trace is that there exists no such package.The org.gwtproject package didn't come until 2.10. So, I made a mistake and filled it out - but I have now removed it from all POMS, there is no reference when I search from it inside IntelliJ or using terminal .find in IntelliJ directories in /Library, but since IntelliJ complains, it must be SOMEWHERE, but where? I can't find it

-So, it would be great if the IntelliJ logs would have given some info, but the only thing it says is some strange mystery temp:temp:pom file but nothing about where it gets the dependency from, nor what file it exists in...

4. Not sure how I would create a sample project since, again, the gwtproject reference is NOWHERE in my files... 


EDIT: for reference, I ran this in the root of my project:

grep -rnw . '--exclude=*.js' -e org.gwtproject - nothing found

Comment actions Permalink

>4. Not sure how I would create a sample project since, again, the gwtproject reference is NOWHERE in my files... 

You can provide the original project. 

This reference may come from GWT SDK that IDE tries to download, if you have GWT, configured in Maven, e.g. have the gwt-maven-plugin.


Please sign in to leave a comment.