My ToolWindow Plugin is no more compatible with Beta New UI Enabled

Answered

If I use the "new ui" then plugin crashes after installing and restarting ide because of anchor="top" to plugin.xml attribute

 

 

 

com.intellij.diagnostic.PluginException: Cannot init toolwindow window.MyToolWindow[,0,0,0x0,invalid,alignmentX=0.0,alignmentY=0.0,border=,flags=0,maximumSize=,minimumSize=,preferredSize=] [Plugin: com.mycompany.myplugin]

 

...

 

Caused by: java.lang.IllegalArgumentException: Anchor=top
    at com.intellij.toolWindow.ToolWindowPaneNewButtonManager.findToolbar(ToolWindowPaneNewButtonManager.kt:127)
    at com.intellij.toolWindow.ToolWindowPaneNewButtonManager.createStripeButton(ToolWindowPaneNewButtonManager.kt:161)
    at com.intellij.openapi.wm.impl.ToolWindowManagerImpl.registerToolWindow$intellij_platform_ide_impl(ToolWindowManagerImpl.kt:1098)
    at com.intellij.toolWindow.ToolWindowSetInitializer.createAndLayoutToolWindows$registerToolWindows(ToolWindowSetInitializer.kt:134)
    ... 34 more

Please sign in to leave a comment.