Did auto adding of quotes for attribute values stop working in latest PhpStorm (2022.3.1)?

Until recently this configuration option was working fine, today I noticed that PhpStorm is not adding the quotes automatically (I updated PhpStorm a few days ago).

Currently, as soon as I type the '=' sign, I see auto-complete suggestions.

What's more - when I choose one of those suggestions, PhpStorm still does not automatically insert the quotes:

If I want to enter double quotes after typing the '=' sign, I actually need to type the equals sign twice! Super annoying.

Is there anyone else out there with a similar issue?


I was not able to quickly reproduce the issue on 2022.3.1.
There is an old incomplete report but no details after that:

A generic question, I understand, but nonetheless -- do you use any custom plugins?


Hi Vasiliy,

Yes, I use custom plugins, but even if I disable all of them, the quotes are not added automatically as previously:

Any idea if there might be some other settings which could be interfering with this?

If it helps, this is my exact PhpStorm version:


Wow, actually I managed to find the culprit: it was the "Generated quote marks" option which was set to "none". I really don't remember changing this one, so I'm still quite confused, but nevertheless it seems to work now.

It's quite confusing in the end - why are there two separate settings for this? You can have the Smart Keys enabled to "add quotes for attribute value on typing `=`", but at the same time you can set those generated quotes to be "none" :-)


Please sign in to leave a comment.