Trying to double-click a text word while part of it is highlighted from Find won't select it

Find box:

Result example:

Since a recent update, if I try to double-click the full word (Ship_To_Phone), nothing else is highlighted, nothing is selected, and I can't copy the word. The cursor (caret?) just moves to the end of the Find result text. This isn't how it worked before.

Now I have to hit Esc to remove the Find box, then I can double-click the word to select:

PhpStorm 2022.3.1

I just tested again to see if the double-clicked text was phantom selected (as in, I could still copy it, but it just didn't look like it), and now it works... I don't know what caused it to not work, but it's happened a handful of times over the last week or so at least.

1 comment
Comment actions Permalink

Thanks for reporting this one, I have managed to reproduce it as well even on a plain text files in PhpStorm 2022.3.1

Just in case, here is the ticket that I submitted on YouTrack:


Please sign in to leave a comment.