All tabs open in "preview mode", even when not debugging



This has been happening since yesterday, not sure why: when opening a new tab from cmd+click on a symbol, it is opening in Preview Mode (the tab title is in italics, and the editor is re-used).

After googling it, it appears this comes from the setting Editor / General / Editor Tabs / Enable preview tab.

The setting was checked, and un-checking it solves the issue - however, according to the description this behavior should only happen when in debugging mode, right? Why is this happening to me while I'm not debugging?

IntelliJ version:

IntelliJ IDEA 2022.3.1 (Ultimate Edition)
Build #IU-223.8214.52, built on December 20, 2022
Licensed to Benoit Lubek
Subscription is active until February 16, 2023.
Runtime version: 17.0.5+1-b653.23 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 13.0.1
GC: G1 Young Generation, G1 Old Generation
Memory: 4096M
Cores: 10
Metal Rendering is ON

Non-Bundled Plugins:
    PsiViewer (2022.3)
    some.awesome (1.14)
    com.github.copilot (
    org.jraf.intellijplugin.nyantray (1.3.0)
    com.intellij.nativeDebug (223.8214.16)
    String Manipulation (9.6.1)
    com.intellij.lang.jsgraphql (3.3.0)
    izhangzhihao.rainbow.brackets (2023.1.1)
    org.jetbrains.kotlin-js-inspection-pack-plugin (0.0.12)
    com.suusan2go.kotlin-fill-class (1.0.17)
    com.apollographql.ijplugin (4.0.0-SNAPSHOT)

Kotlin: 223-1.7.21-release-272-IJ8214.52
Comment actions Permalink

BoD, can you please attach your log file? (`Help | Collect Logs and Diagnostic Data...`)

Comment actions Permalink

BoD, I did not find it in your logs, but you have probably updated Idea, and this has been the default behavior since 2022.2. We are already aware that this is an issue for our users, and we are looking for a solution (

If you would like to keep the preview tab, but open one file in the different editor tabs as many times as you click on it, then change the registry key to false (to access the registry, press Shift-Shift and enter "Registry" in the search dialog). 


Please sign in to leave a comment.