PhpStorm EAP 231 java.lang.UnsupportedClassVersionError

Same error I got with 2022.3 PhpStorm EAP builds: `java.lang.UnsupportedClassVersionError`, while IntelliJ IDEA Ultimate 231 EAP worked fine.


Linux 5.15.0-10058-tuxedo #64tux3 SMP x86_64 x86_64 x86_64 GNU/Linux

Distributor ID:    Ubuntu
Description:    Ubuntu 22.04.1 LTS
Release:    22.04

java --version
openjdk 11.0.17 2022-10-18
OpenJDK Runtime Environment (build 11.0.17+8-post-Ubuntu-1ubuntu222.04)
OpenJDK 64-Bit Server VM (build 11.0.17+8-post-Ubuntu-1ubuntu222.04, mixed mode, sharing)

Error details:

/opt/PhpStorm-231.4840.331/bin$ ./ 
OpenJDK 64-Bit Server VM warning: Archived non-system classes are disabled because the java.system.class.loader property is specified (value = "com.intellij.util.lang.PathClassLoader"). To use archived non-system classes, this property must be not be set
CompileCommand: exclude com/intellij/openapi/vfs/impl/FilePartNodeRoot.trieDescend
Error occurred during initialization of VM
java.lang.UnsupportedClassVersionError: com/intellij/util/lang/PathClassLoader has been compiled by a more recent version of the Java Runtime (class file version 61.0), this version of the Java Runtime only recognizes class file versions up to 55.0
    at java.lang.ClassLoader.defineClass1(java.base@11.0.17/Native Method)
    at java.lang.ClassLoader.defineClass(java.base@11.0.17/
    at jdk.internal.loader.BuiltinClassLoader.defineClass(java.base@11.0.17/
    at jdk.internal.loader.BuiltinClassLoader.findClassOnClassPathOrNull(java.base@11.0.17/
    at jdk.internal.loader.BuiltinClassLoader.loadClassOrNull(java.base@11.0.17/
    at jdk.internal.loader.BuiltinClassLoader.loadClass(java.base@11.0.17/
    at jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(java.base@11.0.17/
    at java.lang.ClassLoader.loadClass(java.base@11.0.17/
    at java.lang.Class.forName0(java.base@11.0.17/Native Method)
    at java.lang.Class.forName(java.base@11.0.17/
    at java.lang.ClassLoader.initSystemClassLoader(java.base@11.0.17/
    at java.lang.System.initPhase3(java.base@11.0.17/



Comment actions Permalink


Could you please download x86 version of PhpStorm for Linux (not Linux ARM64) from

It looks like you accidentally downloaded arm64 build and PhpStorm returns such errors.

Comment actions Permalink

I see. Following your link to nextversion, ARM / aarch64 seems to be the default still, but I could change the version by clicking on the .tar.gz suffix dropdown. 

Comment actions Permalink

The x86 version works! This issue can be closed. Thanks for your quick help!


Please sign in to leave a comment.