Whenever I am trying to load plugins from Marketplace my IntelliJ IDEA Community Edition 2022.3.2 shows that I don't have an internet connection. However I have. I have tried all the techniques in other similar posts but nothing worked for me. What should I do next?


Please, note that you can download plugins manually from the Marketplace site and install it to the IDE using this instruction
Speaking about the IDE Internet connection, please, set up the proxy connection if you use one (Settings | Appearance & Behavior | System Settings | HTTP Proxy), and if it doesn't help, perform the following actions:

  • add the following lines to Help | Diagnostic Tools | Debug Log Settings:
  • restart IDE;
  • reproduce the problem;
  • collect logs using Help | Collect Logs and Diagnostic Data;
  • share the archive with us using JetBrains Uploads service;
  • post the ID you receive here.

Upload id: 2023_02_09_mviZoFRKYJzivRSS2tCtbC (file: idea-logs-20230209-2128044083270271394982374.zip)




Thank you for the provided log. 
Could you please specify which exact solutions you tried to make the connection work? Did you try setting up the idea.connection.timeout value or adding IDE directories to the Windows Defender exclusion settings? 
Also, please provide me with a screenshot of the Settings | Appearance & Behavior | System Settings | HTTP Proxy window if you set up a proxy.



I tried the following solutions:

1. Change the HTTP Proxy settings to auto-detect proxy. After it didn't work I changed back to no-proxy option.

2. Removed a line from Custom VM Options and entered a new line (Screenshot Attached)

3. Entered some lines in Debug Log Settings (Screenshot Attached)


And I didn't set the timeout value to some greater value. Also I didn't added some exclusion in windows defender.

And I don't know what a proxy is? I am just a beginner and trying to learn Java. So I have no clear idea about these things. Please help me out because my colleagues are using some very useful plugins and I am getting behind.

I found something else by searching "proxy" in settings. Just in case it helps, I am providing the screenshot too.



The proxy is a server that stands between your local network and the Internet, and it could be used to filter network traffic. It is often used in educational institutions and in some companies, so you can ask your IT department if your company uses one. 

Also, you can try to add the following line to the Help | Edit Custom VM Options and restart IDE:


Another option worth trying is disabling the Windows Defender firewall or adding IntelliJIDEA to your antivirus exclusion list if you use one.

As I wrote before, you can download the plugins you need manually and install them to the IDE to improve your performance now, and after that, continue troubleshooting to figure out the cause of the connection error.



Upload id: 2023_05_27_YymWqdRdYLK6RN9XN9PzcP (file: phpstorm-logs-20230527-09293011102244732683040928.zip)



Upload id: 2023_05_27_zKV8oHUGURXrz6Znsb1Fob (file: webstorm-logs-20230527-0953524443722292175326304.zip)




Upload id: 2023_05_27_ay76L9LQY6YtCBH91xgMKU (file: goland-logs-20230527-0956071445658580516485968.zip)



Hello raksmey. In the log you shared, I see the Connection timeout error similar to the one discussed above. Could you please try to perform the actions I described in this comment?