Disable Decimal Values for Hex Variable

已完成

Hello,

I couldn't find anything about that but i want to disable that the Goland IDE shows me the Decimal Value after I assigned a hex value. Where's the option to disable this?

0

Hello Vinzenz Weist,

You can change representation of specific variables from the _View as_ item in the context menu.

If you want GoLand to be able to automatically use hexadecimal representation for all hex values, please vote for GO-6317.

0

Hello again, thanks for your help but it seems this is for debugging. I want to disable this view in the code, every variable shows the decimal representation in Editor and this is totally annoying for me. For the debugger i use default integer format hex 

0

Thank you for the clarification Vinzenz Weist. You can disable this feature by clearing the following checkbox: Settings | Editor | Inlay Hints -> Values -> Go. Note that this will disable hints for all types of const values.

0

请先登录再写评论。