Remote development. SSH connection

Trying to connect via SSH to a remote server, I get this error. What should I do?

This IDE build has expired. Provide another build or select 'JetBrains Installer' from the installation options to install the latest version.


It’s about expired EAP build on the backend. Please install new version on there remote server.


Thank you for your reply. I don't need to use PyCharm EAP. Now, when I connect to a remote server, there is only such a version of the IDE for PyCharm

How do I change the size of open tabs in this version? This can usually be done with the mouse. Thank you in advance


This is the latest stable release of PyCharm.

What desktop environment do you use on the local machine?

This error may be due to PyCharm's inability to find or execute the jstack command on the remote server. jstack is a Java tool for generating stack traces of Java threads.

I would suggest u to try as below:

Make sure that Java, especially jstack is installed on your remote server.If not, reinstall it.

Make sure that the jstack command has been added to the server's PATH environment variable. 

Make sure that PyCharm has configured the remote server's environment correctly.

I hope the information is helpful to you!


@Zffz2000 thank you for your willingness to help, but in this case, you're not right, and the problem is in the expired EAP build.


I had a similar problem with WSL2 for kotlin project, so not really for pycharm but very same message:
"This IDE build has expired. Provide another build or select 'JetBrains Installer' from the installation options to install the latest version."

I tried to reinstall and select different builds but nothing really worked. 

The way I managed to solve this issue was essentially to:
- Delete /home/user/.cache/JetBrains folder from your linux environment 

... and worked fine after this. Hope it helps other users. ✌😉

Thanks for the suggestion  Mark Sevelj 


Eduardo Pascoal solution works a treat thank you, if you would like to be a bit less heavy handed you can remove just the /home/user/.cache/JetBrains folder.


I am using PyCharm 2023.3.2 (Professional Edition) Build # PY-233.13135.95 for Windows,  PyCharm 2023.3.2 (233.13135.95) for Linux,a few days ago it has been working normally. 

However, when I disconnected again last night, I was able to connect but couldn't open the IDE. I then switched to PyCharm 2023.3.3 RC (233.13763.5) version, but still had the problem of not opening the IDE. 

I have tried many times, This includes killing processes, delete Windows cache, reinstalling PyCharm for Windows, and PyCharm for Linux.

How can I solve this problem?


Thank you for contacting PyCharm support.

Would you please collect collect logs as per following article?

Don't hesitate to ask if you have any other questions or require further assistance.

Kind regards,
The Drive to Develop

I have also come across this issue. One way I was able to resolve was by selecting “download latest” when opening a new project in remote development


In case anyone else comes across this. I had this issue and the comment above re: jstack was the correct clue for me. I tried running the command on the remote host and it wasn't available. The issue was that I was running a JRE and not a JDK. I installed OpenJDK-17-jdk and it's working again. I'm not sure why this just started. I was previously running a remote IDE fine using a JRE (apparently). I haven't changed anything on the server.


I'm using RubyMine and deleting the /home/user/.cache/JetBrains folder and then opening the project as a fresh one worked.