Toolbox problem on Linux


I installed the Toolbox on Linux several times now,following the official instruction, and I also tried the script that's mentioned on the installation page.

Every time I start the Toolbox, it behaves if it is just installed with the Welcome screen. It also does not remember the login.
But the most serious issue is that nothing can be installed. 'Failed to install <TOOLNAME>, it says, and after that: unknow error.

What is wrong?



Sorry for the inconvenience. Could you please attach toolbox.log?

It can be found under Settings|About or ~/.local/share/JetBrains/Toolbox/logs/


I the meantime it works okay.

I removed the entire JetBrains directory in .local/share in my home directory to make a clean start. This solved the issue.


I found having this problem installing the Toolbox which changed my ~/.profile file.

I found the lines causing this. For me, using zsh, commenting out these lines, so it looks like the following:

# if running bash
#   if [ -n "$BASH_VERSION" ]; then
#       # include .bashrc if it exists
#       if [ -f "$HOME/.bashrc" ]; then
#       . "$HOME/.bashrc"
#       fi
#   fi

solved the problem for me and Toolbox still ran fine.