AttributeError: IN pynguin

Hi, I started using pynguin to generate unit test in an automatic way (don't hesitate if you know other tools that can be more interessting). Thus while execution this command below to generate test 

pynguin --project-path /home/jovyan/projets/tmp/pynguin-results/ \
--output-path /home/jovyan/projets/tmp/pynguin-code-py/ \
--module-name rien 

I have this error

Traceback (most recent call last):
  File "/opt/notebook/bin/pynguin", line 5, in <module>
    from pynguin.cli import main
  File "/opt/notebook/lib64/python3.9/site-packages/pynguin/", line 9, in <module>
    import pynguin.generator as gen
  File "/opt/notebook/lib64/python3.9/site-packages/pynguin/", line 31, in <module>
    import pynguin.analyses.seeding.initialpopulationseeding as initpopseeding
  File "/opt/notebook/lib64/python3.9/site-packages/pynguin/analyses/seeding/", line 17, in <module>
    import as tcc
  File "/opt/notebook/lib64/python3.9/site-packages/pynguin/ga/", line 13, in <module>
    import as chrom
  File "/opt/notebook/lib64/python3.9/site-packages/pynguin/ga/", line 13, in <module>
    import as ff
  File "/opt/notebook/lib64/python3.9/site-packages/pynguin/ga/", line 17, in <module>
    from pynguin.testcase.execution import ExecutionTrace
  File "/opt/notebook/lib64/python3.9/site-packages/pynguin/testcase/", line 428, in <module>
    class ExecutionTracer:
  File "/opt/notebook/lib64/python3.9/site-packages/pynguin/testcase/", line 463, in ExecutionTracer
    Compare.IN: lambda val1, val2: (
  File "/usr/lib64/python3.9/", line 429, in __getattr__
    raise AttributeError(name) from None
AttributeError: IN


Any help




I had the same problem while working with Python 3.9, changing to Python 3.10 and updating to the newest versions of libraries worked for me


Tnks Pavel Im using python 3.11 but I m still having the same error


What is the version of pynguin?