Stop Line Wrapping on Format

Is there any way to stop wrapping lines when formatting blades? if forces spaces in HTML that I don't want there. For some context.

In my blade I have a line something like this.

{{ round(($case->low_limit_amount/1000), 0) }}K/{{ round(($case->high_limit_amount/1000), 0) }}K
Translation 50K/100K
When formatted...

{{ round(($case->low_limit_amount/1000), 0) }}
K/{{ round(($case->high_limit_amount/1000), 0) }}K

Translation 50 K/100K (50<space>K/100K)


0

Hi there,

1) Can you please provide actual sample file (just in case; at least the part that gets reformatted like that)

2) Please also share your Code Style

So far it looks like your line is longer than your right margin for HTML files so it reformats to make it fit. If so -- either increase that number for HTML .. or maybe some other way (e.g. if this text is inside <p> then configure it to never break/reformat <p> content .. which is not ideal)

0

Have same issue.

In a pure html, I have a snippet like this:

```

<div class="alert alert-success">

一些中文在这里一些中文在这里。一些中文在这里一些中文在这里。一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里。一些中文在这里一些中文在这里一些中文在这里一些中。文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里。一些中文在这里一些中文在这里。

</div>

```

All text should be in one line.

 

AFTER FORMATTED,TEXT BREAKS TO SEVERAL LINES:

```

一些中文在这里一些中文在这里。一些中文在这里一些中文在这里。一些中文在这里一些中文在这里一些中
文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一
些中文在这里。一些中文在这里一些中文在这里一些中文在这里一些中。文在这里一些中文在这里一些中文在
这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里。一些中文在这里一些中文在这里。

```

AND WHEN BROWSE IT, TEXT LOOKS LIKE:

```

一些中文在这里一些中文在这里。一些中文在这里一些中文在这里。一些中文在这里一些中文在这里一些中 文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里一 些中文在这里。一些中文在这里一些中文在这里一些中文在这里一些中。文在这里一些中文在这里一些中文在 这里一些中文在这里一些中文在这里一些中文在这里一些中文在这里。一些中文在这里一些中文在这里。

```

EVERY LINE BREAK SHOWS AS A SPACE.

 

COULD YOU PLEASE TELL ME HOW TO SETUP TO AVOID THIS?

 

0

@Chnyyk

Look at options in "Settings/Preferences | Editor | Code Style | HTML".

Default scheme does not break anything in your example for me...

0

请先登录再写评论。