Disable "Automatic thread dumps"

已回答

I'm pretty satisfy with IDEA performance and don't mention any lags or freezes.

But for some reason when I checks log directory (~/Library/Logs/IntelliJIdea2016.3) I see a lot of threadDumps-* folders with a lot of freeze-* folders with one or several threadDump-* files in them. This files take a space (currently around 500Mb) and only increase.

How can I disable "Automatic thread dumps" completely or at last increase freeze duration when such dump creates?

2
-Dperformance.watcher.interval=0

Add this line to VM Options (https://intellij-support.jetbrains.com/hc/articles/206544869).

0

Great! Seems it works :). Thank you.

0

@Serge Baranov

 

I added

-Dperformance.watcher.interval=0

to my

~/PhpStorm2017.3/config/phpstorm64.vmoptions

In 'idea.log' I see it

2018-01-11 18:47:52,026 [ 33] INFO - #com.intellij.idea.Main - JVM Args: -agentpath:/usr/local/phpstorm/bin/libyjpagent-linux64.so=disablealloc,delay=10000,probe_disable=*,sessionname=PhpStorm2017.3 -Xbootclasspath/a:/usr/local/phpstorm/lib/boot.jar -Xms128m -Xmx1536m -XX:ReservedCodeCacheSize=240m -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -XX:MaxJavaStackTraceDepth=-1 -Dawt.useSystemAAFontSettings=lcd -Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine -Dperformance.watcher.interval=0 -XX:ErrorFile=/home/aj/java_error_in_PHPSTORM_%p.log -XX:HeapDumpPath=/home/aj/java_error_in_PHPSTORM.hprof -Didea.paths.selector=PhpStorm2017.3 -Djb.vmOptionsFile=/home/aj/.PhpStorm2017.3/config/phpstorm64.vmoptions -Didea.platform.prefix=PhpStorm -Didea.jre.check=true

Even with that,

cd ~/PhpStorm2017.3/system/log
ls -al
total 388K
drwxrwx--- 38 aj users 4.0K Jan 12 06:31 ./
drwxrwx--- 19 aj users 4.0K Jan 11 18:48 ../
-rw-r--r-- 1 aj users 234K Jan 11 21:04 idea.log
drwxr-xr-x 2 aj users 4.0K Jan 11 22:30 threadDumps-freeze-20180111-221855-PS-173.4301.15-693sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 22:45 threadDumps-freeze-20180111-224357-PS-173.4301.15-94sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 22:46 threadDumps-freeze-20180111-224626-PS-173.4301.15-33sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 22:52 threadDumps-freeze-20180111-225117-PS-173.4301.15-103sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 22:54 threadDumps-freeze-20180111-225332-PS-173.4301.15-41sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 23:00 threadDumps-freeze-20180111-225909-PS-173.4301.15-65sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 23:01 threadDumps-freeze-20180111-230025-PS-173.4301.15-93sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 23:10 threadDumps-freeze-20180111-230956-PS-173.4301.15-77sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 23:15 threadDumps-freeze-20180111-231503-PS-173.4301.15-33sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 23:19 threadDumps-freeze-20180111-231642-PS-173.4301.15-150sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 23:31 threadDumps-freeze-20180111-233039-PS-173.4301.15-72sec/
drwxr-xr-x 2 aj users 4.0K Jan 11 23:35 threadDumps-freeze-20180111-233503-PS-173.4301.15-50sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:03 threadDumps-freeze-20180112-010222-PS-173.4301.15-55sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:09 threadDumps-freeze-20180112-010824-PS-173.4301.15-112sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:11 threadDumps-freeze-20180112-011013-PS-173.4301.15-109sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:14 threadDumps-freeze-20180112-011327-PS-173.4301.15-67sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:19 threadDumps-freeze-20180112-011739-PS-173.4301.15-109sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:26 threadDumps-freeze-20180112-012551-PS-173.4301.15-62sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:33 threadDumps-freeze-20180112-013147-PS-173.4301.15-110sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:36 threadDumps-freeze-20180112-013434-PS-173.4301.15-137sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 01:56 threadDumps-freeze-20180112-015600-PS-173.4301.15-40sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 02:03 threadDumps-freeze-20180112-020301-PS-173.4301.15-29sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 02:08 threadDumps-freeze-20180112-020730-PS-173.4301.15-37sec/
drwxrwxrwx 2 aj users 4.0K Jan 12 02:15 threadDumps-freeze-20180112-021210-PS-173.4301.15-175sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 03:24 threadDumps-freeze-20180112-032206-PS-173.4301.15-118sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 03:26 threadDumps-freeze-20180112-032604-PS-173.4301.15-56sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 04:09 threadDumps-freeze-20180112-040653-PS-173.4301.15-202sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 04:22 threadDumps-freeze-20180112-042159-PS-173.4301.15-39sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 05:39 threadDumps-freeze-20180112-053632-PS-173.4301.15-193sec/
drwxrwxrwx 2 aj users 4.0K Jan 12 05:40 threadDumps-freeze-20180112-054022-PS-173.4301.15-35sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 05:50 threadDumps-freeze-20180112-054438-PS-173.4301.15-339sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 05:57 threadDumps-freeze-20180112-055718-PS-173.4301.15-36sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 06:01 threadDumps-freeze-20180112-055952-PS-173.4301.15-130sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 06:20 threadDumps-freeze-20180112-062025-PS-173.4301.15-43sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 06:25 threadDumps-freeze-20180112-062359-PS-173.4301.15-112sec/
drwxr-xr-x 2 aj users 4.0K Jan 12 06:31 threadDumps-freeze-20180112-063100-PS-173.4301.15-48sec/

Something else needed to turn these off?
0

Double check this option is visible in Help | Edit Custom VM Options.

0

@Serge Baranov

 

It's in there

...

-Dawt.useSystemAAFontSettings=lcd
-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
-Dperformance.watcher.interval=0
0

It appears the property has been renamed to 

performance.watcher.unresponsive.interval.ms

So, you need to add

-Dperformance.watcher.unresponsive.interval.ms=0

in Help | Edit Custom VM Options now.

0

@Serge Baranov

Changed that, restarted.

No more trace* DIRS, and in log I see only related INFO level

...
2018-01-12 10:57:26,660 [ 21339] INFO - .openapi.application.Preloader - Finished preloading com.intellij.ide.ui.search.SearchableOptionPreloader@7dd866fe
! 2018-01-12 10:57:26,768 [ 21447] INFO - PerformancePlugin - Performance Plugin is in silent mode
2018-01-12 10:57:29,492 [ 24171] INFO - .openapi.application.Preloader - Finished preloading com.intellij.codeInsight.completion.CompletionPreloader@7c0567d0
! 2018-01-12 10:57:32,179 [ 26858] INFO - .diagnostic.PerformanceWatcher - Pushing properties took 3052ms; general responsiveness: ok; EDT responsiveness: 1/1 sluggish
2018-01-12 10:57:33,296 [ 27975] INFO - tartup.impl.StartupManagerImpl - OpenFilesActivity run in 4745ms under project opening modal progress
2018-01-12 10:57:33,476 [ 28155] INFO - tartup.impl.StartupManagerImpl - InitToolWindowsActivity run in 180ms under project opening modal progress
! 2018-01-12 10:57:33,661 [ 28340] INFO - .diagnostic.PerformanceWatcher - Post-startup activities under progress took 5218ms; general responsiveness: ok; EDT responsiveness: 3/6 sluggish, 3/6 very slow
2018-01-12 10:57:41,942 [ 36621] INFO - j.ide.ui.OptionsTopHitProvider - 1652 ms spent to cache options in application
! 2018-01-12 10:57:42,619 [ 37298] INFO - .diagnostic.PerformanceWatcher - Indexable file iteration took 10421ms; general responsiveness: ok; EDT responsiveness: 4/13 sluggish, 9/13 very slow
2018-01-12 10:57:42,625 [ 37304] INFO - indexing.UnindexedFilesUpdater - Unindexed files update started: 3981 files to update
2018-01-12 10:57:42,707 [ 37386] INFO - git4idea.GitVcs - Git version: 2.15.1.0 (UNIX)
2018-01-12 10:57:44,630 [ 39309] ERROR - terminal.emulator.JediEmulator - Unknown character attribute:10
2018-01-12 10:57:44,632 [ 39311] ERROR - terminal.emulator.JediEmulator - Unknown character attribute:10
...

Seems OK for now

0

I'd recommend reporting the performance problems at https://youtrack.jetbrains.com/issues/IDEA instead of hiding them.

0

Do we need to restart the IDE for it to work?

0

Yes, restart is needed when changing any .vmoptions or .properties.

1

Have added -Dperformance.watcher.unresponsive.interval.ms=0 to custom vm options

 

Still seeing thread dumps folders being created

version - 2023.2.4

0

It looks like the code was changed and there is no longer a way to disable it.

0

Serge Baranov Because of automatic thread dump. Intellij app is not responding .cpu usage,disk speed,memory usage goes skyrocket . we would like the feature to be added back please.

0

IDE is not responding because of some other issue which is causing these dumps to be recorded. Please contact support with the thread dumps attached so that we can help you with this problem: https://intellij-support.jetbrains.com/hc/requests/new.

0

请先登录再写评论。