Can't open IntelliJ on MacOs

已回答

When launching IntelliJ Ultimate (2016.3) I get:

The application “IntelliJ IDEA” can’t be opened.

Tried restarting and reinstalling, for no luck.

评论操作 固定链接

Rajeshchilukuri Tech

https://youtrack.jetbrains.com/issue/IDEA-274515 is likely the case. Sorry for the inconvenience. Reinstalling should help.

0
评论操作 固定链接

Простите что по русски)

Неожиданное завершение intellij IDEA 2021.3.2. Версия MacOS 10.15.7.

Устанавливал и более раннюю версию - не помогло. CE работает прекрасно. Удалял CE, переустанавливал, результат не изменился.

Заранее благодарю за помощь

0
评论操作 固定链接

Awlwlb попробуйте шаги из https://intellij-support.jetbrains.com/hc/en-us/articles/360007568559.

Если не помогает, запустите из командной строки и предоставьте лог: https://intellij-support.jetbrains.com/hc/en-us/articles/360011901879-How-to-start-IDE-from-the-command-line.

По-русски лучше писать напрямую через тикет в поддержку: https://intellij-support.jetbrains.com/hc/requests/new.

0
评论操作 固定链接

Hi, Serge, I have the same problem with launching the IntelliJ IDEA. I've downloaded the file "idealU-2022.1.2-aarch64.dmg". It was dragged to Applications, but still not starts. Icon appears in the Dock, but then nothing happens. Could you please help me in this question? Thank you in advance.

0
评论操作 固定链接

Vladimir Barikov 85 We need the full log from the command line after starting the IDE in the terminal per https://intellij-support.jetbrains.com/hc/en-us/articles/360011901879-How-to-start-IDE-from-the-command-line.

If it freezes, we'd also need the thread dumps via jstack: https://intellij-support.jetbrains.com/hc/en-us/articles/206544899.

You can upload the files at https://uploads.jetbrains.com and provide the ID here or create a ticket with the files attached at https://intellij-support.jetbrains.com/hc/requests/new.

0
评论操作 固定链接

Hi Serge, 

I installed JAVA JDK actual version and then I reinstalled EDI. It works now.

Thank you for support.

 

0
评论操作 固定链接

Hi Serge Baranov,

My mac is Intel based. I have downloaded intel based Intellij 2022.2 from the https://www.jetbrains.com/toolbox/app But unfortunately am not able to open the application via terminal. Please find the below log. Kindly assist me on how to fix this.

/Applications/IntelliJ\ IDEA.app/Contents/MacOS/idea

2022-08-08 22:22:05.253 idea[1464:43479] allVms required 1.8*,1.8+

2022-08-08 22:22:05.257 idea[1464:43486] Cannot load JVM bundle: Error Domain=NSCocoaErrorDomain Code=3585 "dlopen_preflight(/Applications/IntelliJ IDEA.app/Contents/jbr/Contents/MacOS/libjli.dylib): no suitable image found.  Did find:

/Applications/IntelliJ IDEA.app/Contents/jbr/Contents/MacOS/libjli.dylib: mach-o, but wrong architecture

/Applications/IntelliJ IDEA.app/Contents/jbr/Contents/MacOS/libjli.dylib: mach-o, but wrong architecture" UserInfo={NSLocalizedFailureReason=The bundle doesn’t contain a version for the current architecture., NSLocalizedRecoverySuggestion=Try installing a universal version of the bundle., NSFilePath=/Applications/IntelliJ IDEA.app/Contents/jbr/Contents/MacOS/libjli.dylib, NSDebugDescription=dlopen_preflight(/Applications/IntelliJ IDEA.app/Contents/jbr/Contents/MacOS/libjli.dylib): no suitable image found.  Did find:

/Applications/IntelliJ IDEA.app/Contents/jbr/Contents/MacOS/libjli.dylib: mach-o, but wrong architecture

/Applications/IntelliJ IDEA.app/Contents/jbr/Contents/MacOS/libjli.dylib: mach-o, but wrong architecture, NSBundlePath=/Applications/IntelliJ IDEA.app/Contents/jbr, NSLocalizedDescription=The bundle “JBR-17.0.3+7-469.32-jcef 17.0.3” couldn’t be loaded because it doesn’t contain a version for the current architecture.}

Thanks in Advance,

Narmatha

0
评论操作 固定链接

Thanks for the help! Serge Baranov, It worked. May i know why the issue came up in my previous installation

0
评论操作 固定链接

Hello! @Serge Baranov

Could you please help me look into this issue?

It seems the InteliJ cannot opent for I changed the heap size?

Here's the error message I got:

Last login: Thu Aug 11 15:36:22 on console

zhhshan@88665a51fdb2 ~ % /Applications/IntelliJ\ IDEA.app/Contents/MacOS/idea

2022-08-11 15:41:15.149 idea[2120:15185] allVms required 1.8*,1.8+

2022-08-11 15:41:15.151 idea[2120:15188] Current Directory: /Users/zhhshan

2022-08-11 15:41:15.151 idea[2120:15188] parseVMOptions: IDEA_VM_OPTIONS = (null)

2022-08-11 15:41:15.151 idea[2120:15188] fullFileName is: /Applications/IntelliJ IDEA.app/Contents/bin/idea.vmoptions

2022-08-11 15:41:15.151 idea[2120:15188] fullFileName exists: /Applications/IntelliJ IDEA.app/Contents/bin/idea.vmoptions

2022-08-11 15:41:15.151 idea[2120:15188] parseVMOptions: /Applications/IntelliJ IDEA.app/Contents/bin/idea.vmoptions

2022-08-11 15:41:15.151 idea[2120:15188] parseVMOptions: /Applications/IntelliJ IDEA.app.vmoptions

2022-08-11 15:41:15.154 idea[2120:15188] parseVMOptions: /Users/zhhshan/Library/Application Support/JetBrains/IntelliJIdea2021.3/idea.vmoptions

And I've tried removing idea.vmoptions.

2022-08-11 15:41:15.154 idea[2120:15188] parseVMOptions: platform=17 user=4 file=/Users/zhhshan/Library/Application Support/JetBrains/IntelliJIdea2021.3/idea.vmoptions

Invalid initial heap size: -Xms2048m -Xmx2048m

Invalid initial heap size: -Xms2048m -Xmx2048m

2022-08-11 15:41:15.163 idea[2120:15188] JNI_CreateJavaVM (/Applications/IntelliJ IDEA.app/Contents/jbr) failed: -6

P.S. I've tried removed/edited the idea.vmoptions file; reinstall still cannot resolve the problem.

-Xms128m
-Xmx750m
-XX:ReservedCodeCacheSize=2048m
-XX:+IgnoreUnrecognizedVMOptions
-XX:+UseG1GC
-XX:SoftRefLRUPolicyMSPerMB=50
-XX:CICompilerCount=2
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-ea
-Dsun.io.useCanonCaches=false
-Djdk.http.auth.tunneling.disabledSchemes=""
-Djdk.attach.allowAttachSelf=true
-Djdk.module.illegalAccess.silent=true
-Dkotlinx.coroutines.debug=off
-XX:ErrorFile=$USER_HOME/java_error_in_idea_%p.log
-XX:HeapDumpPath=$USER_HOME/java_error_in_idea.hprof

0
评论操作 固定链接

Huishanzhang2021 There are two vmoptions files, make sure none of them contains invalid options:

/Applications/IntelliJ IDEA.app/Contents/bin/idea.vmoptions
/Users/zhhshan/Library/Application Support/JetBrains/IntelliJIdea2021.3/idea.vmoptions

There may be also OS wide environment variables set that override the VM options:

JAVA_TOOL_OPTIONS
JDK_JAVA_OPTIONS
_JAVA_OPTIONS

Run `env` command in the Terminal to ensure you don't have any of these set.

0

请先登录再写评论。