Problem with new Linux default font for 2017.1


After installing, 2017.1, there default font looks different.  Went to settings/appearance and am still going with the default font (deja vu sans 13) but can't locate the previously used font.

Anyone else see this or could this be due to some update to my fedora system which was done at the same time?


I've seen this on an Ubuntu 16.04 installation so it's not local to your Fedora environment.  The change from 2016 -> 2017 has introduced a default font change that looks pretty darned different.


I'm on Yakkety Yak (16.10), and no other font is offered than this DejaVu Sans 13. This is a serious readability and thus productivity issue for me!


Brought this up (but wasn't explicit) as the font renders very poorly and readability is an issue as Csaba mentions.  It's not just I feel like changing it for fun.


Anyone knows what was the old font (I wish I checked before) in the old 2016.x PyCharm in Linux, so once we can figure out how to set it to something else we cans et it back to that one?


Mh4, can you rename the topic, like "2017.1 Linux lame font" or something?


The same problem here (Ubuntu 16.04). The same font as in 2016 version, but rendering is really bad now


I just upgraded a few minutes ago, and immediately noticed the font change. My preferred font from PyCharm 2016.3, "DejaVu Sans Mono" is still selected in the font settings dialog. However, PyCharm is silently substituting "Monospaced" instead.

The problem seems to be specific to DejaVu Sans Mono. Other fonts seem to work fine in 2017.1. The older PyCharm is still working correctly. 

I even tried removing DejaVu Sans from the system fonts and putting copy in my local user fonts (~/.fonts) folder. That didn't help either. 

Other fonts in the IDE (labels, buttons) are different as well. I'm on Mint 17.3 (Ubuntu 14.04).


@Seth so the font "DejaVu Sans Mono" was what we saw in the older version, just cannot be resolved with the 2017. My bigger problem was that I couldn't even select anything else. Now fonts appeared in the drop-down, but non of them is as readable as "DejaVu Sans Mono" was, and on top of that my selection only affects mainly the editor. I want the console to be readable, etc. I wonder if this problem present in the IntelliJ IDEA as well.


It'd be great to see someone from JetBrains chime in here. Otherwise I'll write a proper support ticket soon.


Filed an issue


java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

Looking at AskUbuntu and other place people advise various fonts. I just want the old font back, that worked.



How somebody in bugtracker said. For quick fix it just about replacing new jre folder in your Pycharm folder with the older one. Now I have the same rendered font as with old version


I experienced the same issue with Ubuntu 16.04, at the end I reverted back to the previous version, 2016.1.

With that version everything is fine. This is very annoying.


I also have reverted back to 2016.3. Fonts in 2017.1 are too ugly and I can't use it.  I think JetBrains has test his products more carefully before the release.


Installed 2017.1.1 and now I'm back to a different very thin, non-substantial font than I was last night. 

Jetbrains, what are the proper setting to get back to the original font?


9 years have past

still same problem

still no reply from IDEA team

still eclipse looks and feels much better

still occasionally have to use idea because of "formatting standards" at work.



Indeed, very disappointing, to say the least.

Luckily, the only thing affected for me is the Error Console.



Hi Amel,

When do you have the error?

Have you tried the proposed by PyCharm solutions?

If problem is totally different from described in this post originally, I think it will be better to create another one for your problem.


I can confirm using the 64 bit openjdk jetbrains java boot jdk fixes this on ubuntu 16.04 for pycharm.

previously i was using oracle java 


I was very disappointed with the font when using the following combination,

  • Ubuntu 19.04
  • WebStorm 2019.2 (Also 2017.3)
  • OpenJDK VM by Jetbrains

Setting the following property in WebStorm.vmsettings solved the problem,


This was originally proposed here,