[Docker Setting]Connection refused on localhost:2375

已回答

Hello, while setting docker (for Windows) on PHPStorm I'v got following connection refused message 

 

Any idea on possible causes or log to check ?

 PHPStorm 2017.1.4 - 171.4694.2

Thank you

 

5

I'v found, Docker for Windows (and mac I suppose) must be set to expose daemon :

 

18

Thanks florent......this work for me......great job

 

1

Is there a way to do this without exposing the local Docker installation to remote code execution attacks yet?

4

Hello,

I have exactly the same error message but I have already exposed daemon on tcp://localhost:2375 without TLS to on for my Docker Desktop.

I am running under windows 10  with docker desktop 2.1.0.2 and Engine 19.03.2

If i run docker compose with my docker-compose file , in terminal, it works.

If anybody, have any idea , it will be very wellcome !

Thanks 

Mehdi

3

Check if all tools are correctly detected at File | Settings | Build, Execution, Deployment | Docker | Tools. It's difficult to "guess" what's wrong there - I would rather recommend contacting us via Help > Contact Support

 

0

I am getting the same error as @Mehdichati, dockers are running fine, but IDEA can't connect to docker service. All settings at  File | Settings | Build, Execution, Deployment | Docker | Tools are pointing on files that are physically there

1

Tools don't matter here, the IntelliJ platform communicates with Docker over Docker remote API.
Here's the message you should get: http://prntscr.com/ppuv86
If you don't get it, or get an error message, please check if you can connect to the same port via telnet.

0

JetBrains, how hard is to enable TLS in this day and age?  We've been waiting over a year now for a 5 minute fix to avoid a remote code execution vulnerability.  I find myself slowly drifting towards VSCode lately (its docker-explorer extension does support TLS).  Lucky for you, their PHP debugger is still lagging way behind, so we'll still keep up our subscription for a bit yet, even if I have to switch IDEs every few minutes.  VSC is outpacing you for JS & Docker - get it together before they cover all the same bases!

4

I'm also facing with  the same issue as MEHIDI 's . If anyone found solution please post it.

Thanks
Vimal

0

请先登录再写评论。