Intellij IDE caret following cursor


Having an issue with IntelliJ where the caret (I-Beam thing - I think) follows the cursor without clicking. It will also start a selection when I do click as seen in the attachment below. I'm using the most up to date community edition of IntelliJ on arch Linux. It also happens within any pop out windows in IntelliJ, but not any other application. 


I have tried disabling all plugins, the problem persisted.

I have tried reinstalling IntelliJ, the problem persisted.

I also cannot right click because of this issue.


Any had this problem before or could help?




Do you have similar problem in other Java Swing applications like NetBeans or JEdit?

Does it help if you remove IDE folders ( to start with all the defaults?


Hey Serge,

No, this does not happen in other applications. I have also tried removing the files, but that also did not fix the issue.


What other Java Swing apps did you test with?


I have tried this with NetBeans.


Do you have any window manager customizations related to the focus and mouse behavior? Something like "focus follows mouse" may cause it.


Hey Serge,

No, I don't have any altered focus settings.


What window manager and Linux distribution version do you use? Does it happen with 2017.2.4 build from


Hey Serve, 

I'm using Arch with Gnome. I will try with the other version soon



Hi Serge

I am experiencing the exact same issue (currently using Gogland):

  • If I click in any editable field in the UI, including the editor itself, it starts a selection
  • The cursor follows the mouse within focused editable UI fields and the editor
  • Right click has no effect

This had been happening sporadically and restarting Gogland would fix it, but now even restarting Gogland has no effect.

I'm running Ubuntu and using the Gnome 3 desktop environment.


Please file a ticket at with the detailed information about your environment so that we can reproduce it (exact versions of Ubuntu/Gnome, related packages, etc, also attach idea.log,


I have been suffering exact same problem since I upgraded to Ubuntu 17.10.

I am running

IntelliJ IDEA 2017.2.5
Build #IU-172.4343.14, built on September 26, 2017
Licensed to XXXXX
Subscription is active until January 4, 2018
JRE: 1.8.0_152-release-915-b12 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.13.0-16-lowlatency


However I just tried JEdit; it froze for a while and then I selected 'File - New in mode' and it started working: The exciting part is that Intellij is now working correctly; this makes a much more acceptable workaround than a reboot, if repeatable.



I'm having the exact same problem in Webstorm and Phpstom (but oddly not in Goland). restarting the IDEs doesn't help (only system restart helps). it's really annoying and making the products not usable.

I'm suspecting that it's a Gnome + Intellij problem since all reporter here are using it.

GNOME Shell 3.18.5
Webstorm 2017.2.5
Phpstorm 2017.2.4
Ubuntu 16.04.3 LTS



I followed the instructions here 

a couple of weeks ago, and problem seems to have gone away 

My intellj details now are


IntelliJ IDEA 2017.2.6
Build #IU-172.4574.11, built on November 13, 2017
Licensed to XXXX
Subscription is active until January 4, 2018
JRE: 1.8.0_152-release-1038-b6 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.13.0-17-generic```




Out of interest, for those with the issue, do you have a touchscreen? I've recently found a link between this issue and using my touchscreen...


@BenH Thanks for your reply .. will try this out, but which version of JB SDK have you chosen?


@Danewatts97 yes in fact I have a touch screen,


@Danewatts97 Yes I have a touch screen

@Foj I just installed the one with the largest version number (which wasn't thet default; that dialog sorts alphabetically rather than alphanumerically)


I found a super easy fix for this issue!

If you have a touch screen and this issue started to happen, just touch the screen to change the caret position in the IDE and it will stop it from following the cursor!


@Foj, Yes this was exactly what I was going to suggest. I have NO IDEA why it happens or why this fixes it but 


SOLUTION: If you have a touchscreen, touch it and it will SOLVE this issue.


@Serge maybe this needs to be reported as a bug to investigate.



+1 on the issue. It happens on my Dell XPS-15 (9560) with Ubuntu 17.10 and IntelliJ IDEA 2017.3.1

IntelliJ IDEA 2017.3.1 (Ultimate Edition)
Build #IU-173.3942.27, built on December 11, 2017
JRE: 1.8.0_152-release-1024-b8 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.13.10-041310-generic

and also +1 on the solution. Touching the screen will make the problem go away. That is at the moment a much better solution than rebooting.

Has a ticket been made? I can update it with my info


@Serge I do not think this is the same issue,as BetterTouchTools is on a Mac and the above happens on Linux. Also the procedure to make it happen cannot be reproduced (at least not on my setup)




In this case feel free to report another issue. I can't find anything related in YouTrack.


Now created as issue:

The issue is referencing this community post.


@Danewatts97 Thanks, I had this issue as well and it was the touch screen causing the problem.


Touching the touchscreen fixed it for me too. I'm using a Dell laptop and Gnome with Wayland.


Dell XPS 15 9560

Ubuntu 18.04

PhpStorm 2018.2.3


Touching the screen solved the issue...


Touching the screen also solved it for me


After one year same here: 

xps 13 9370

ubuntu 18.04

webstorm 2018.2.5


Nobody should touch my screen  (;´༎ຶД༎ຶ`)


I am having this same problem on Ubuntu 18.04 and Ubuntu 18.10

It seems others have confirmed if two mouse devices are attached in Linux, it happens. In many situations this is caused by a Touch-Screen laptop LCD, which behaves as one mouse pointer control, and the main touchpad.  I found more independent reports of the problem here:


Touching the screen once solved the problem. Thank god I found this place.