Extreme lag and high CPU usage on OSX High Sierra

Today I upgraded from OSX Sierra to High Sierra. Everything ran smoothly, until I opened PhpStorm. Suddenly, the system started lagging badly. Switching tasks between PhpStorm and other apps (Chrome) took 2-3 seconds. Switching between editors inside PhpStorm took 1-2 seconds.

I noticed, that the CPU usage of PhpStorm went up to 50%-80%, when moving the cursor in PhpStorm or when switching between editor windows. Indexing a project completely freezed the system with a CPU usage of 600%.

Then I uninstalled JAVA and JAVA SDK and rebooted. Suddenly everything ran fine, even in PhpStorm.

But now I have PhpStorm (EAP 2017.3 Build #PS-173.3531.17) open for almost an hour, and the lag when switching tasks/editors starts to appear again. It's almost impossible to work.

I also tried PhpStorm 2017.2, but same problem there.

Any ideas how to fix this?

118 条评论


Do you have a support request number we could look into? This place is a forum: it's more of an open discussion place. If we start to troubleshoot individual issues right here - this thread would be filled with tonns of logs & suggestions (just like comments section in https://youtrack.jetbrains.com/issue/JRE-526). Other users would be having hard times following this thread.

If you're sure that you're experiencing an issue different from https://youtrack.jetbrains.com/issue/JRE-526 - please submit a support request using Help > New Support Request. Every request is reviewed and action plan is advised in each case.


If your issue is related to 4K-display slowness - unfortunately there are no updates on this. The best option for you is to subscribe to notifications of https://youtrack.jetbrains.com/issue/JRE-526 by voting for/commenting it.


This can't be fixed by JetBrains, this is an OS glitch, Apple are the ones to fix it!


Did anybody try to update the graphics drivers to the latest version provided by Nvidia (or ATI, probably)? I found this issue because I was having massive performance issues under High Sierra, however I'm not using Intellij, but some other Java-based tool. Nonetheless, for me, using the latest driver made a huge difference, and things run a lot smoother now.

I'm running a MacBook Pro Mid 2014, system information tells me that the used Geforce driver provided by Apple was 355.11, which was released in 2015...
So YMMV based on how old your system is. I have no idea if this driver was updated for later MacBooks.


If you have a mid 2014 MBP, you have a GeForce GT 750M chipset. And there are no new Nvidia drivers for that chipset and OSX.

The newest Nvidia drivers are for Mac Pro users custom Nvidia cards.


Correct 2014 MBP, GeForce GT 750M. I installed the drivers directly from nVidia: https://images.nvidia.com/mac/pkg/378/WebDriver-378.

They work perfectly fine, and System Report lists those GeforceWeb drivers as being loaded and used, instead of the ones provided by Apple.


The official Nvidia page for that driver only lists beta support for older MacBooks (2012, 2013) and doesn't list the 750M in the supported products:


So theoretically, this would be the wrong driver for a 2014 MBP with GeForce 750M?



I have a mid-2014 MBP with NVIDIA GeForce GT 750M. Have been suffering using PhpStorm on a 4K external display, needing to keep the IDE window smaller than usual to avoid the performance problem. I just installed the package linked to in Joerg's comment, and OMG, it works! Thank you.

Aside: after installing the driver package, the MBP wouldn't boot - stuck on the Apple logo for an hour. I went into recovery mode (which it didn't want to do either at first... gulp), and 'repaired' the SSD. No issues found, but on rebooting everything was back to normal. No issues on second reboot.


@Florian: You're right. I haven't come across that page before (luckily, otherwise I might not have tried the driver). Might also be that nVidia is just a bit vague with the models listed there. Wikipedia lists both, the late 2013 and mid 2014, as MacBookPro11,3. Both have a 750M installed.
I haven't tried running games or anything 3D with the new driver, so maybe there could be some glitches. But as long as I can work again...

@David: Glad that this worked for you to! :) 


Also was having the same issue on mid 2014 MBP (750m) 16GB 512GB SSD with OSX 10.13.1 - installed nvidia's drivers at https://images.nvidia.com/mac/pkg/378/WebDriver-378. and things seem right again - not just with intellij but with everything in the OS. Why did apple not include these in an update??? seems crazy to me b/c I was about to throw my mac at the wall.


@Joerg I came across this driver a few days ago, after someone proposed it as a solution to the external 4k problem. But after reading the specs I wasn't convinced to install it.

I will make a backup tomorrow and try it out.

@Rbgrn Did you also have the same issues like @David after installing the driver and rebooting?


@Florian No issues so far. It rebooted, everything went back to normal like 10.12


I installed the drivers today. Even during installation it is mentioned, that the drivers are only for Mac Pros. But hey, it worked! Everything is snappy as it used to be. Even the MBP dying during sleepmode (only when the 4k monitor was connected) is gone!


I was seeing this exact problem - Idea was unusable with 2 second lag between keystrokes. Mouse wheel scrolling in many apps was laggy and video playback was jerky.

I was unable to install the driver linked by Joerg. It said it wasn't compatible with the OS version I was using. However, I found that if it starts getting laggy, I can switch resolutions on my 4k monitor to a low resolution, then switch it back and things are responsive again. Co-workers with less-than-4k monitors are not seeing the problem at all. Clearly a driver issue. 

Macbook Pro Mid-2014 NVIDIA GeForce GT 750M 2 GB

Thank you for all the suggestions that led to a solution for me.


Nvidia deactivated its driver after I rebooted my MBP today, because of incompatibilities with my current OS (like @Dustin mentioned). Probably because of the security patch for the hilarious Root-Bug from Apple.

There is a new version of the Nvidia Driver available (378., but Nvidia won't download it because of compatibility issues.

Apple starts to seriously annoy me...


I'm way past annoyed... I haven't rebooted since the security fix. Hopefully I won't have to in the near future.

I found a script in this thread which seems to bypass the OS version check. But that's getting more hacky...

Is there a good way to let Apple know of this issue? I don't have high hopes, but if enough people (or maybe a company with a proper support contract (JetBrains?)) complain they might move.


@Joerg: You better reboot. The security bug is pretty bad, as it enables anyone to log in as admin on any High Sierra machine.

Thanks for the link, but I'm not really fond of downloading and executing a shell script. There's also a hack here. But I just saw that my MPB added a second security fix. I'm guessing that Nvidia might release a 378. soon. At least I hope so.

As for contacting Apple: Yes please, if someone has enough authority.


Nvidia released a new 378. driver, which seems to work again on High Sierra 10.13.1 with the 2 recent security patches.


That driver also works for me on the latest High Sierra version. Unfortunately, some people have problems installing it: https://youtrack.jetbrains.com/issue/JRE-526#comment=27-2575620
So please be careful if someone tries this driver. After all, the outdated driver seems to be just one issue causing these lags, as also the latest MBPs seem to be affected, and at least I hope they use recent drivers there...


OK, everyone mentions the drive, but for Mid 2014. I have a late 2013 machine, so where can I find that driver?




@Mark The driver is for Mac Pro (not even Macbooks), with "beta support for 2012 Macbooks". So theoretically not for a 2014 MBP or later. That's why I also hesitated installing it. But the weird thing is: it works (at least for some of us).

Make sure to backup your system before trying out any drivers.


RubyMine crashes every 5 minutes and application fails to respond when connected to an external monitor! I am on MacOS Sierra (  10.12.6 ) and latest RubyMine version. ( 2017.3) 


@Asma Tameem

That sounds like an issue not related to this topic. Please post more details in a separate thread or via Help > New Support Request


Hey all, just want to throw in my 2 cents.

I use a whole suite of JetBrains products on my High Sierra 15" MacBook Pro (Mid 2014, dedicated Nvidia card). I experience this issue constantly. Whether its with RubyMine, Datagrip, etc.

I've seen it mentioned that it's related to 4k+ resolution. I don't believe that to be the only case. If I'm using my laptop with no external screens attached, it happens. If I connect my 1440p display and/or 1080p display, it happens. System slows to an absolute crawl, and in my case it just locks up entirely after a while. Very rustling. 

Worth noting perhaps is that I experience none of these issue using the products on my Linux machine. It's only High Sierra, and it's across a slew of JetBrains products.

No solution yet, but it's driving me up the wall.


I've been following this thread and commented earlier.

I ended up opening a ticket with JetBrains where we tried numerous IDE settings, removing plugins and installing a new JRE.

I have also installed the NVIDIA driver patch.  

While I agree you may see better performance when you do not use a 4k monitor, the issue does not go away completely with regular monitors.  Because I have nothing to lose, I have tried other ideas that temporarily resolve the delay:  If I unplug my HDMI cord, then plug it back in, this sometimes fixes the issue.  If I quit and restart my IDE, this sometimes fixes the issue.  If I close my screen and repoen, this sometimes fixes the issue. 

This delay started happening after I upgrading to HIgh Sierra - period.  Meaning, I don't think this is related to some weird IDE setting.  I appreciate Jetbains support chasing symptoms, but the root cause and accountability of this lies squarely with Apple.  Maybe we would get attention if this were happening on our new Apple phones... oh right.. I don't have one fo those (good).  Very frustrated and losing $$$$ with this.


For those of you on Mid 2014 MBPs with 750m chip (like myself) that are having issues - after installing the nvidia web driver, did you reboot and then make sure that the "NVIDIA Web Driver" on the new nvidia driver manager drop down was selected? After updating, it reverted me back to the OSX driver until I selected it and rebooted, then everything was good again.



The solution is very simple. Just remove phpStorm and all settings in /Users/user/Library/Preferences/PhpStorm2017.3 then make clean install and don't import any old settings and plugins. That works for me. Index tooks only 2 minutes and no more freezes!


I have the exact same issue. I thought it was firefox, so i switched to chrome and everything was good... until i re-opened PhpStorm


I tried all listed fixes in this and another thread and had little progress. I did notice that running Webstorm in a window on my 4k display that performance was unbearable. Changing to full-screen mode made it behave perfectly. So until a fix comes out, I'm running in full screen mode.


My computer was almost unusable.

It looks like people have different problems and different solutions too, so you can try this: disable hardware acceleration in chrome preference.

My computer is now like under sierra.


Putting Webstorm on High Sierra in fullscreen mode helped me a lot! Thanks for sharing your experience Bendalton.

I am working on an external monitor Dell u2515h with native resolution (2560x1440) connected to macbook pro 2015 with ati graphic card.