Extreme lag and high CPU usage on OSX High Sierra

Today I upgraded from OSX Sierra to High Sierra. Everything ran smoothly, until I opened PhpStorm. Suddenly, the system started lagging badly. Switching tasks between PhpStorm and other apps (Chrome) took 2-3 seconds. Switching between editors inside PhpStorm took 1-2 seconds.

I noticed, that the CPU usage of PhpStorm went up to 50%-80%, when moving the cursor in PhpStorm or when switching between editor windows. Indexing a project completely freezed the system with a CPU usage of 600%.

Then I uninstalled JAVA and JAVA SDK and rebooted. Suddenly everything ran fine, even in PhpStorm.

But now I have PhpStorm (EAP 2017.3 Build #PS-173.3531.17) open for almost an hour, and the lag when switching tasks/editors starts to appear again. It's almost impossible to work.

I also tried PhpStorm 2017.2, but same problem there.

Any ideas how to fix this?

118 条评论

Dear support,

is there any news on a bugfix in progress? It is highly disturbing that for a product like this and the costs associated, the support is non-responsive. I am currently evaluating cancelling my licence and switching IDEs. Please share an update. The problem seems not only linked to external displays or 4k issues. I run solely on a MacBook Pro 15" and i got the same challenge


Pro tip: reducing and disabling things are called "workarounds", not "solutions"


Hi there,

TL;DR: Try to override default font to native internal SanFrancisco font, named .SF NS Text

I believe this issue is somehow related to Java font rendering in newer OS X versions. Actually, I had exactly the same issue with XMind app (it uses Eclipse under the hood) - at some moment, even small (<20 elements) mind map rendering started to lag entire OS. And the solution in my case was the same - just using system-native font, which is now SanFrancisco family SFUIText.

Hope it helps to somebody.




I also have lags in PhpStorm on MacOS High Sierra. All other functions in OS runs perfectly fast. I have iMac retina i5 16gb ram, ssd. Its terrible situations which doesnt allow normal work. I think about change IDE at this moment and cancel license. No respond from Support with appropriate fix, update.


Working with the 2018.x versions, in my setup, is impossible. Late 2014 imac 5k with High Sierra. Keyboard clicks are lost, scrolling is unstable, mouse clicks take a long time to just open a menu. Tried almost any suggestion here without any luck. I thought 2018.2 would fix things but to no avail.  Now using 2017.3.6 and everything is back to normal.

Update 15 Oct 2018: Tried 2018.3 EAP (183.3647.13). All symptoms of strange behaviour are still there. So back to 2017.3.6

Update 14 Dec 2018: 2018.3.1 works as expected. No noticeable issues. 



Dustin, I see what you're saying, but it's irrelevant in my humble opinion. Every other application runs just fine on High Sierra except PhpStorm. If they claim to support OS X then that means they have to make it run smoothly on that OS. This is clearly not the case as many users are complaining about the same problem. Besides that this isn't new to High Sierra, I've been a PhpStorm user for several years and performance has been a recurring issue.

I feel cheated for having to try to figure out how to make PhpStorm work smoothly every time there's a product or OS update. I pay for this product to make my life easier not harder.


Actually I have the exact same issue.. so it dont think it is an individual challenge. Can you please share the solution to this?


Also having the same issue on High Sierra.  I've got the latest Macbook Pro with 2.9 Ghz i7 and 16GB Ram.


Same issue here. Makes the computer almost unusable. Late 2013 MacBook Pro 2.3 GHz i7, 16 GB RAM. It took about 3 minutes to type this comment...


Ok guys apparently OS X High Sierra is a piece of crap. Can't wait for them to make it lighter and optimized.

But there is a solution, update JDK to latest version, in my case reinstall java downloaded from the oracle site and now it's okay, not perfect, but with 1-2 glitches on the scroll when going to the IDE desktop and then it's 60fps again.

Hope it helps for now!


Same problem here using PHPStorm on a 5K iMac. I updated my MBP last week and it works fine there, so took the plunge with the iMac... wish I hadn't now..!

The issue seems very similar to the one which prompted the bundled JDK a couple of years ago. Shrinking the PHPStorm window from maximised to 1/4 screen completely eliminates the problem, as it did back then.

To the good folk at JetBrains - is there some way of warning others not to update OSX, until there's a fix for this?



Correct 2014 MBP, GeForce GT 750M. I installed the drivers directly from nVidia: https://images.nvidia.com/mac/pkg/378/WebDriver-378.

They work perfectly fine, and System Report lists those GeforceWeb drivers as being loaded and used, instead of the ones provided by Apple.


There is some conflict between NVIDIA GeForce GT 750M and High Sierra and IDEA products and possibly 4k monitors, although it might be more general than that from what I've read here. Personally I tried everything I could think of -- running in low-res mode, installing the new NVIDIA drivers, trying different monitors, and I still couldn't stand the choppiness. As a programmer, it doesn't look like a performance issue to me. The hitching feels more like a thread deadlock issue at a very low level.

Personally, I gave up. I reformatted my hard drive and reinstalled the old Sierra. Everything is back to smooth and fast, like the Mac I remember. It sucks, and it took 3 full days to get all my data and apps reinstalled and configured, but at least I didn't have to spend $3,400 on a new Mac. I stopped using IDEA products -- I felt too annoyed by their lack of support and non-existent development response on this issue -- but maybe I'll go back to them after I get over it emotionally. 


Is this ever going to be resolved? I won't accept the standard finger-pointing at the OS or other factors outside of the product. You're offering support for OS X, you're taking money from your loyal OS X users and we're expecting you to fix any problems that come up. This has been going on for so long already and it's completely unacceptable.


Hi ... same problem here. We just get some new displays with (QHD 2.560 × 1.440) ... we scaled the resolution to 1080p HiDPI. Now we have high lags when entering code and the CPU increase. On the internal Display everything is smooth. 

System: MacBook Pro 2015
2,7 GHz Intel Core i5
8GB Memory
Graphics Intel Iris Graphics 6100

2 external Displays: Dell P2418D with 1080 HiDPI

Have the following PHPStorm versions tried:

PhpStorm 2018.3
PhpStorm 2019.1

both with JRE: 11-internal+125 x86_64
and default JRE 8

I hope there will be a solution soon. Can't work properly. :(



Performance issues are very hard to troubleshoot as each of them depends on particular environment and project. Therefore it is advised to contact support directly if you experience slow performance issues.

I can see that you already contacted support regarding that matter - team will assist you with troubleshooting and resolving this.


I'm really glad to see this posted here because I'm experiencing the same issue in IntelliJ. It's maddening to have my system act so slowly. Just like OP, my performance suffers when I hit CMD+TAB to switch between apps. While in IntelliJ, performance seems decent. Much awaiting a fix on this.


Is there any update by any chance? Rollback to Sierra is not an option.


Get the same issue with webstorm. CPU occupy 200%!


Ребят, вы конечно сделали шикарный редактор, но из-за такой ерунды по сути вы теряете пользователей. Ни я последний наверное буду искать альтернативу ( Очень жаль, но проц что пхпсторм, что идея жрут нещадно - овер 300%


Did anybody try to update the graphics drivers to the latest version provided by Nvidia (or ATI, probably)? I found this issue because I was having massive performance issues under High Sierra, however I'm not using Intellij, but some other Java-based tool. Nonetheless, for me, using the latest driver made a huge difference, and things run a lot smoother now.

I'm running a MacBook Pro Mid 2014, system information tells me that the used Geforce driver provided by Apple was 355.11, which was released in 2015...
So YMMV based on how old your system is. I have no idea if this driver was updated for later MacBooks.


I had this issue, and it was all related to my 4K monitor. I noticed when i went to work and used my 1080p monitor, all was fine, when i would come back home and hook up to my 4k monitor, everything went to hell. Finally I read somewhere, maybe even this post, that if you lower the resolution it corrects it. I corrected my issue by going to Settings -> Displays, Select scaled and select the second from the largest resolution, though i hate losing the screen resolution, at least i can work now. 


For anyone experiencing this issue, I've managed to improve things greatly by modifying the scaling settings on my external display (which is a 4K). I set it to the furthest option to the right (more space), essentially telling MacOS to not scale the display at all. This makes the UI elements and fonts very small, but I just jacked up the font size in the IDE. It's not a perfect solution, but the performance is like night and day.


I recently tried Intellij IDEA 2018.2 RC build and the issue still seems to be present. The CPU range will vary from 300% to 600% just typing basically half the system cores are completely pegged. 

My Setup:

2X 4K Samsung 28" monitors (I close the lid of my laptop so I only have 2 screens active, not 3) The resolution is set to look like 2560 X 1440 on both screens

Late 2016 Macbook Pro Retina (2.7 GHz, 16GB RAM, Randon Pro 455 2GB)

I've tried playing with different JVM settings and garbage collectors with no performance changes. I have tried a couple different monitor and resolution configurations as well. I can confirm what some others have mentioned. If I run the screens at true 4K resolution the performance does improve, but for me readability goes to hell making this an undesirable solution. I've also observed performance increases when only a single 4K monitor is connected vs two. As other have mentioned changing the Antialiasing to Greyscale or turning it off completely also improves performance.

On Windows I don't see these performance issues. I even took both my 4K monitors to my Windows machine and ran Intellij with DPI scaling on. There wasn't any impact to the performance.

I'll be curious if things improve under Mojave but I'm not going to hold my breath given how long this issue has been around. 


Well, here I am at Mojave, short after making fun of my friends macbook with 8gb ram gone obsolete. He was struggling with this issues for some time (being on high sierra), and I did not believe him.

Now i've upgraded my MacBook Pro (Retina, Mid 2012) i7 @ 16GB straight from sierra to mojave aaaand now i'm having the same issue. I've tried the font trick and it makes things slightly better, the app is usable, but it's still not the same silence, fans are whirring frequently.

So i'm supporting an opinion that crappy OS updates are still JetBrains problem, if we are paying a subscribtion fee for a product, such things should be fixed ASAP.


Same issue here using IntelliJ on High Sierra.


IntelliJ IDEA 2017.2.5
Build #IC-172.4343.14, built on September 25, 2017
JRE: 1.8.0_152-release-915-b12 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.13.1


It's recommended to investigate this individually using Help > New Support Request