I got a new laptop this week. The first things I've installed were CLion and mingw. After installation, I started CLion (mingw has already been installed beforehand). My Window Defender kept prompting that it had found trojans. I looked further, it was in the CMake folder:

I installed CLion few months ago on a different computer and never had this problem. Is something wrong?


Yes, on Tuesday December 6, Windows randomly started giving me repeated notifications that it had found some malware and was removing it. It didn't remove it automatically, so I manually went to windows defender and found the 2-3 infected files with the tiggre!plock trojan and deleted them. Prompty after when I tried to work on a clion project, it said cmake failed and the program/code wasn't a part of any project, thus preventing me from doing any programming as I couldn't test/compile/run it. After hours of repeated (windows has found some malware) notifications, I decided to take a closer look at the file path and realized it was from cmake files within the jetbrains clion folder, inside of each project if I remember correctly. Unfortunately, I was forced to delete clion and as of yet, I haven't received the notification.


Hi all!

We have a related issue in our tracker - Please comment or upvote it to get updates.

Is it possible to try adding cmake.exe process to the antivirus exceptions?


I was getting the same issue when trying to set up the toolchain for CLion. I just ignored the warning, and manually selected the make, gcc, c++ executable paths from the MinGW (or Cygwin) install locations. After that, I was able to compile my project and move on with no further issues.


I get the same issue a lot of times. I tried to fix it but couldn't. After all, I gave up and delete CLion. Please fix it....


Any fix from jetbrains? is it a false positive?


Could you please try using the workarounds from Does that help?


I also faced the issue. I just updated the packages in MINGW and I tried again on CLION. After updating my bitdefender anti-virus didn't detect anything as threat.