PhpStorm keeps indexing over and over again

已回答

PhpStorm keeps reindexing over and over again.

Tried to restart the app, but wouldn't solve the problem.

17

FILE | invalidate caches and restart seems to have fixed it.

34

@Rémy thanks it works for me

0

Worked for me to. Thanks!

0

@Rémy 

Works ! 

The issue occured in my case when i switched project locations.

1

@Rémy THANK YOU!

0

Yep, that did the trick for me also. Thanks.

0

Same problem, same solution for RubyMine. Thank you

0

Obrigado Remy, deu certinho aqui!

-1

Works, many thanks!

0

Thanks, this solves my issue. I moved project locations.

0

Go to File -> Invalidate Caches and Restart.  Fixed my issue - https://www.prodjex.com/2018/03/phpstorm-stuck-re-indexing/

1

Yo tambien tenia el mismo problema, si lo solvente con "Invalidate Caches and Restart"
me ocurrio por tener el proyecto en un disco externo. 

-2

invalidate caches and restart just helped me, too

PhpStorm 2017.3.6
Build #PS-173.4674.46, built on March 15, 2018
JRE: 1.8.0_152-release-1024-b15 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.13.3

-1

Yes, seems to have fixed the problem. Wow did that problem make it hard to concentrate.

PhpStorm 2017.3.6
Build #PS-173.4674.46, built on March 15, 2018
JRE: 1.8.0_152-release-1024-b15 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.6

0

File -> Invalidate Caches and Restart is not solving the problem for me!

Manjaro Linux (latest)

WebStorm (latest)

Angular (latest, huge project)

0

Invalidate Caches / Restart is not working for me... I have cloned a new copy from a repo and PyCharm start to "updating indices". Why does it scan from /home/my-home and not only the project's directory?

0

Invalidate Caches / Restart is not working for me :(

PhpStorm 2018.1
Build #PS-181.4203.565, built on March 28, 2018
JRE: 1.8.0_152-release-1136-b20 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.5
0

@Jarek please update to 2018.1.6 - it contains tons of fixes compared with vanilla 2018.1 build.

-1

This is the phpstorm version I'm using, and the issue still exists.

PhpStorm 2018.1.6
Build #PS-181.5281.35, built on June 14, 2018
Licensed to Curve Dental / Hung Nguyen
Subscription is active until February 22, 2019
JRE: 1.8.0_152-release-1136-b39 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.4.0-31-generic

0

Did not work for me.

PhpStorm 2018.2.2
Build #PS-182.4129.45, built on August 22, 2018
JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.12.6

0

Anna, could you please install the latest PhpStorm version? (2019.1.2 or 2018.2.7 if you have to stick with 2018.2.*)

-1

This does not help at all! It keeps indexing node_modules even when it's excluded. It all started again since two updates to php storm.

PhpStorm 2019.1.2
Build #PS-191.7141.52, built on May 8, 2019
JRE: 1.8.0_202-release-1483-b49 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

1

The same happens today with `node_modules` after `git pull && yarn install`. Yesterday it just worked as usual. After resetting to previous commit and invalidating cache usual indexing was restored. But we should continue work with `new node_modules`.

 

PhpStorm 2019.2
Build #PS-192.5728.108, built on July 24, 2019

Runtime version: 11.0.3+12-b304.10 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.0.0-23-generic
GC: ParNew, ConcurrentMarkSweep
Memory: 725M
Cores: 4
Registry: run.processes.with.pty=TRUE
Non-Bundled Plugins: com.alayouni.ansiHighlight, com.intellij.ideolog, org.jetbrains.plugins.go-template, org.jetbrains.plugins.stylus, com.stylint, com.jetbrains.lang.ejs, de.espend.idea.laravel, com.intellij.kubernetes, org.zalando.intellij.swagger, ru.adelf.idea.dotenv

0

Invalidating caches didn't work for me.

What solved my case was:

  1. Exit all instances of JetBrains (PhpStorm, PyCharm and Datagrip in my case)
  2. rm -rf .idea on all projects with indexing loop
  3. I've also rolledback a version of phpstorm that I've installed the day before, may have also helped.
1

Fixed in WebStorm 2019.3 EAP 193.4099.10 for a node_modules infinite indexing.

 

Thanks, JetBrains

0

For anyone on MacOS Catalina. I was having an issue where every time I'd come back to PhpStorm from a different Application, it'd close all the open tabs and re-index. I didn't have this problem before upgrading my OS. I tried the "Invalidate Caches / Restart..." but that didn't work. The one thing that did seem to work for me was going into System Preferences -> Security & Privacy -> Privacy -> Full Disk Access and giving PhpStorm full access instead of the scoped access that it had which in my case was just the "Documents" folder. This solved the issue for me.

PhpStorm 2019.2.4
macOS 10.15.1

1

Thank @Fermanjii. I've been having the same problem. Does anyone know which path to use for PHPStorm.app if we're using JetBrains Toolbox? I'm trying ~/Applications/JetBrains Toolbox/PHPStorm.app, even though that's not really where it is (maybe it's a pointer, I'm not sure).

0

You could always find out the installation path for a specific app in JetBrains Toolbox by clicking the "gear" icon near the app name and check the "Installation path" field.

Hope it helps!

0

请先登录再写评论。