Constant indexing... something... over and over?

When I'm not in the PHPStorm window (on Windows) it has recently (since setting up my repo again) been flashing the orange/yellowish bar across its taskbar icon (indicating it's trying to tell me something updated I guess, which is usually useless and distracting to me anyways), and when I click into it, it keeps popping up the Indexing spinner at the bottom then disappears, over and over and over again...

I have to pause it to get the little pop-up to stick and show me what it's indexing, but the pathname it shows its truncated with an ellipsis so I can't tell which file it's indexing or if it's the same file or different ones each time...

Normally I'm used to the Indexing spinner staying until it's indexing all files, but it appears to be trying the same one over and over or restarting the indexer for each file... I'm not seeing how to even troubleshoot this or see what's going on.


Do you have build tools or file watchers setup (grunt/gulp,js compressor, sass compiler, etc...)? You can upload somewhere your idea.log file (Help > Show log in ..) of us to look at.




I don't know, I just installed the latest PHPStorm, re-cloned my repo (since I needed to change folders and wanted to start fresh anyways), and ran into this weird indexing issue...

I found a forum thread suggesting to "invalidate cache", which I did, which apparently fixed the problem. However, I don't understand why PHPStorm is indexing the cache after a clone, or anytime really. I'd like it to index files and code that's actually there.

Also, part of my point was that there was no way for me to see which file it was indexing, because the little pop-up box at the bottom right that opens when I click to see what's indexing truncates the file's path with an ellipsis... there's nothing to click to see the full path, so I couldn't tell if it was indexing the same file over and over again, or even if it was changing folders.


FILE | invalidate caches and restart seems to have fixed it. Easy and works for me! 

Source: Rémy (émy)


Go to File -> Invalidate Caches and Restart.  Fixed my issue -


Invalidating caches and restart has resolved my issues. Before that the log was full of the following errors:

2018-03-21 09:49:41,747 [8104140] ERROR - stubs.StubProcessingHelperBase - WebStorm 2017.3.5 Build #WS-173.4674.32
2018-03-21 09:49:41,747 [8104140] ERROR - stubs.StubProcessingHelperBase - JDK: 1.8.0_152-release
2018-03-21 09:49:41,747 [8104140] ERROR - stubs.StubProcessingHelperBase - VM: OpenJDK 64-Bit Server VM
2018-03-21 09:49:41,747 [8104140] ERROR - stubs.StubProcessingHelperBase - Vendor: JetBrains s.r.o
2018-03-21 09:49:41,747 [8104140] ERROR - stubs.StubProcessingHelperBase - OS: Linux
2018-03-21 09:49:41,747 [8104140] ERROR - stubs.StubProcessingHelperBase - Last Action: ShowLog
2018-03-21 09:49:41,746 [8104139] ERROR - stubs.StubProcessingHelperBase - Stub index points to a file without PSI: com.intellij.openapi.fileTypes.UnknownFileType@7db4a8b7
java.lang.Throwable: Stub index points to a file without PSI: com.intellij.openapi.fileTypes.UnknownFileType@7db4a8b7
at com.intellij.openapi.diagnostic.Logger.error(
at com.intellij.psi.stubs.StubProcessingHelperBase.processStubsInFile(
at com.intellij.psi.stubs.StubIndexImpl$2.process(
at com.intellij.psi.stubs.StubIndexImpl$StubIdListContainerAction.perform(
at com.intellij.psi.stubs.StubIndexImpl$StubIdListContainerAction.perform(
at com.intellij.util.indexing.ValueContainer.forEach(
at com.intellij.psi.stubs.StubIndexImpl.a(
at com.intellij.psi.stubs.StubIndexImpl.processElements(
at com.intellij.psi.stubs.StubIndexImpl.processElements(
at com.intellij.lang.javascript.psi.resolve.JSClassResolver.processElementsByQNameIncludingImplicit(
at com.intellij.lang.javascript.psi.resolve.JSReferenceExpressionResolver.processAllSymbols(
at com.intellij.lang.javascript.psi.resolve.JSReferenceExpressionResolver.processAllSymbols(
at com.intellij.lang.javascript.psi.resolve.JSReferenceExpressionResolver.resolveFromIndices(
at com.intellij.lang.javascript.psi.resolve.JSReferenceExpressionResolver.resolve(
at com.intellij.lang.javascript.psi.resolve.JSReferenceExpressionResolver.resolve(
at com.intellij.psi.impl.source.resolve.ResolveCache.resolve(
at com.intellij.psi.impl.source.resolve.ResolveCache.resolveWithCaching(
at com.intellij.psi.impl.source.resolve.ResolveCache.resolveWithCaching(
at com.intellij.lang.javascript.psi.resolve.JSResolveUtil.resolve(
at com.intellij.lang.javascript.psi.impl.JSReferenceExpressionImpl.multiResolve(
at com.intellij.lang.javascript.psi.impl.JSReferenceExpressionImpl.resolve(
at com.intellij.lang.javascript.inspections.JSDeprecatedSymbolsInspection$1.visitJSReferenceExpression(
at com.intellij.lang.javascript.psi.impl.JSReferenceExpressionImpl.accept(
at com.intellij.codeInspection.InspectionEngine.acceptElements(
at com.intellij.codeInspection.InspectionEngine.createVisitorAndAcceptElements(
at com.intellij.codeInsight.daemon.impl.LocalInspectionsPass.a(
at com.intellij.codeInsight.daemon.impl.LocalInspectionsPass.a(
at com.intellij.concurrency.ApplierCompleter.c(
at com.intellij.openapi.application.impl.ApplicationImpl.tryRunReadAction(
at com.intellij.concurrency.ApplierCompleter.a(
at com.intellij.openapi.progress.impl.CoreProgressManager.a(
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(
at com.intellij.concurrency.ApplierCompleter.b(
at com.intellij.concurrency.ApplierCompleter.b(
at com.intellij.openapi.application.impl.ReadMostlyRWLock.executeByImpatientReader(
at com.intellij.openapi.application.impl.ApplicationImpl.executeByImpatientReader(
at com.intellij.concurrency.ApplierCompleter.compute(
at java.util.concurrent.CountedCompleter.exec(
at java.util.concurrent.ForkJoinTask.doExec(
at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(
at java.util.concurrent.ForkJoinPool.runWorker(


I can confirm that invalidate cache also fixes this issue for IntelliJ


File -> Invalidate Caches and Restart is not solving the problem for me!

Manjaro Linux (latest)

WebStorm (latest)

Angular (latest, huge project)


On IntelliJ Idea Ultimate, issue is present, constant, and restarting, invalidating the cache has no effect whatsoever 


There's a chance that it's the .ignore plugin that triggers constant re-indexing. Please disable it if you have it enabled and check again.


Reverting PyCharm Professional from 2018.01 to 2017.03 for Mac solved the problem for me!  (Invalidating cache however did not)


I am using WebStorm 2018 with Ubuntu 17.04 and invalidate cache/restart worked with me. 


Invalidating the cache and restarting was not working for me, but disabling the .ignore plugin fixed it.

Now I'm not distracted by the indexing, but I do miss the .ignore plugin.


Same Issue in IDEA 2018.2

removing ignore plugin seemed to do it



In my case, constant reindexing was caused when I accidentally removed read permission for the project root directory; restoring the permission solved the problem. (Also, loads of log entries about virtual files not being found were generated.)


It's just ridiculous at this point.

I'm really considering leaving JetBrains all together for VSCode. 

Can't really work, it keeps indexing every time that I run a test suit.


Can't really work, it keeps indexing every time that I run a test suit.

Could it be that your test suite generates a lot of files in the project?
If so, it makes sense to exclude the folder where the generated files are located from indexing at Settings | Directories.


Hi! Found this thread before fixing it on my own.

Not sure if this is useful for anyone else, but here goes:

I had the same issue, but further checking yielded that it was indexing a lot of flat files on disk. I had referenced a folder for the BigData tool and added a bunch of files into that folder. Enough files to make the indexer shoot itself.

I cleared the cache, removed files and everything went back to normal.


So, so, so annoying, please fix it. Its too slow. Have to wait for an hour for a package to reindex. Seriously! I am moving to VS code thanks to this.