PHPStorm absurd behaviors

I tried to open an HTML file from a remote server. The "Open with" option does not find PHPStorm.
I then uninstalled Toolbox and reinstalled PHPStorm, this time "Open with" sees PHPStorm.

I opened the HTML file, in default LightEdit mode, at some point I had to undo the last change I made but I got this error: "The following files have changes that cannot be undone: Problem file....."

I can't undo an operation?

I had to download Vscode, retrieve an old backup copy of the file and restore it. 
An hour of work for a change that would have taken no more than 20 seconds.

Then I tried to turn on full IDE mode, but it even asks me if I want to open the file in a project or in a new project.
Is this for real?

Should I use another editor to make changes?

I hope it is me doing something wrong, in case explain, thanks



This is curious, I have all PhpStorm instances installed via the JetBrains Toolbox in "Open with" context menu, here is the list for .php files:

What OS are you using?
Have you enabled the "Create file associations" option?


Also, I may confirm that Undo works fine in the LightEdit mode as well.

You did mention the Remote Server, what kind of server is it? (SMB, S/FTP, etc)
Is it accessible like a regular file system?