[Pycharm] always indexing everytime opened, anyone else encountering this too?

已回答

I'm using PyCharm 2022.3.3 (Professional Edition) on Windows10.

I find that (nearly) everytime I open Pycharm it starts indexing, but I never install/uninstall/update any python/conda packages, nor update a lot of files in my project directory. Actually there aren't many files in my project (like around 15 python .py files). I even marked the `.git` folder as excluded.

It's just like i code for a while in the afternoon, and when i reopen pycharm in the evening, it starts indexing again.

Does anybody else encounter this problem too? Is there any effective solution to this? This is a bit too annoying and would literally ruin my coding experience :(. Desperately wanted a solution.

8

Hi. My problem is every morning when I wake my laptop and open up pycharm it reindexes. Nothing has changed since the night before. And i get a "local history is broken" message despite having turned local history off. This was not happening in pycharm 2022. But ever since i upgraded to 2023 it happens every day. Is this just me or are there others reporting this?

1

I've encountered the same issue. Previous version didn't had the problem and now, everytime I launch Pycharm it reindex.

1

Same issue.  [upvote]  It happens to me on opening the app every day.  PyCharm 2023.1.4 (Pro) build# PY-231.9225.15 on Ubuntu 22.04.2 LTS.  Plenty of available disk.

I do see at least one message like this in idea.log (not comfortable posting full stack trace, and it's very long):

"WARN - #xxxxxx.ProjectFrameAllocator - Cannot load project in 10 seconds"

1

Have the same issue for the last 1 year or so. Every time I open PyCharm I need to wait for it to reindex everything (current PyCharm version 2023.2.1 but I think it started with either 2022 or 2023 version).

1

I have the same problem since i upgraded from 2022 to PyCharm 2023.1.2 (Professional Edition) Build #PY-231.9011.38, built on May 16, 2023.

(mac, montery, m1 pro)

I get "unable to save settings" and "connection failed too many files open" messages while it indexes. I tried invalidating cache but everytime I open my mac and switch to the pycharm app its reindexing.

0
Hi, PyCharm indexes everything it fins in PYTHONPATH and content roots which you can see in the project structure settings. If you don't see any directories outside your project there, please submit an issue to https://youtrack.jetbrains.com/issues/py and provide the following:

- logs from **Help | Collect Logs and Diagnostic Data**
- Screenshot of your [interpreter settings](https://www.jetbrains.com/help/pycharm/configuring-python-interpreter.html)
0
I don't recall similar reports recently. Do you keep PyCharm open overnight, or do you launch a new PyCharm process after waking up the laptop?
0

i keep it open overnight. (Btw. im not the original poster who also had this issue).

0

If it helps, im using a remote python 3.11.3 docker compose interpreter. 

0
Very interesting. I would still suggest submitting an issue to https://youtrack.jetbrains.com/issues/py providing the debug log that can be collected as follows:

1) Add the following lines to **Help | Diagnostic Tools | Debug Log Settings...**:

```
#com.jetbrains.python.sdk.PythonSdkUpdater$Trigger
```

(keep the # character)

2) Reproduce the issue and provide logs from **Help | Collect Logs and Diagnostic Data**.
0

For me, it's even worse. It runs indexing every few minutes when I just editing one file from the project.

0

Same here, running PyCharm 2023.1.2 (Professional Edition)

Build #PY-231.9011.38, built on May 16, 2023

Runtime version: 17.0.6+10-b829.9 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.

On Macbook Pro 2017 Intel Version

Why does it reindex every few minutes even though nothing changed, not even in libraries? Is there a way to disable auto indexing and instead manually index whenever needed? It's a workflow killer.

0

To everyone experiencing this issue:

Please file a separate ticket to https://youtrack.jetbrains.com/issues/PY and describe your issue. Provide a CPU snapshot (see “The CPU usage is high or IDE is slow” section in https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems) along with your logs folder zipped (Help | Collect Logs and Diagnostic Data). Please do not use existing tickets to report your problem as each one should be investigated separately.

0

帖子评论已关闭。