DataSpell R Console "Process was terminated"

Process was terminated

Process finished with exit code -1073740940 (0xC0000374)

No code or steps needed for reproducing as it will happen even if I open DataSpell and do nothing. 

I am using version 2023.1.2 on Windows 11 22621.1702. All plug-ins are up to date. I believe this issue is linked to a windows problem of displaying text for non-unicode programs.

I was getting locale error in DataSpell R console after every command and this resulted in a disfunction of the plotting window. I switched on the "Beta: Use Unicode UTF-8 for worldwide language support" option in windows region settings and this solved the issue until today.

Today the new error appeared as described above, switching the option on and off cannot solve this issue, changing language for non-unicode programs to English did not help either. In contrast R Studio works just fine.




I have the same error on my MacOS machine using DataSpell 2023.3.2 and R 4.3.2 (from homebrew)

R session starts with warning message 

During startup - Warning message:
Setting LC_CTYPE failed, using "C" 

But most of the R commands are failing, for example

> library(ggplot2)
> ggplot(diamonds)
Process was terminated

Process finished with exit code 133 (interrupted by signal 5:SIGTRAP)