PyCharm creates virtual environment for Python 3.11 but not for 3.8 in Debian 12

Hello,

I'm testing Debian 12 and I have installed PyCharm 2023.1.4 Pro. With the default python 3.11 I can create new virtual environments using the settings window and everything runs properly.

For a certain project I need Python 3.8, so I installed the python 3.8.17 (following the general instructions with a make altinstall to allow both versions) but with 3.8 version I can't create the virtual environment from PyCharm. I added the 3.8 version as a system environment also, but nothing changes.

If I create the venv manually with the command python3.8 -m venv venv-3.8/ and after that I add an existing virtual environment everything works normally (the terminal uses the venv, I can install normally the requirements, etc.)

I can't figure out what I'm doing wrong.

Thank you for your help.

0
Hello,
Please take screenshot of venv creation window and attach it to the thread. 
Also, please reproduce the problem and upload idea.log (Help | Show logs in...) here: https://uploads.services.jetbrains.com/
0

Hello,

I'm feeling stupid. Today I can create the venvs without any issues. Don't know what was doing wrong. Sure I logged out and in but not sure rebooted the computer.

Sorry to make loose your time.

Thank you.

0

请先登录再写评论。