Pycharm after updating to 2023.2 the new terminal window doesn't activates the venv

Once I've updated the new pycharm version, the new terminal window doesn't activate the python venv

I've played around with all possible settings and surfed through the net about solutions for such issues and have not succeeded.

What can be the issue of that?
Maybe you have any advices for a solution?

1
Could you please specify the path to your current project interpreter, and if you have "activate virtualenv" option enabled in the terminal settings?
0

Thanks for your response!

Here is the example of my project interpreter path  

~/Folder/project_folder/venv/bin/python

The activate_virtualenv is enabled in my settings.

Any thoughts?

Here is the screenshot of the settings:

0
The settings look ok. Could you please provide logs from **Help | Collect Logs and Diagnostic Data** after starting up the terminal, and also the output of `echo $VIRTUAL_ENV` command from the terminal.
0
2023-07-30 18:19:05,295 [158008495]   INFO - #o.j.p.t.LocalTerminalDirectRunner - Started com.pty4j.unix.UnixPtyProcess in 79 ms from [/bin/zsh, --login, -i] in /path/to/project/project_folder, [columns=203, rows=14], diff_envs={FIG_JETBRAINS_SHELL_INTEGRATION=1, JEDITERM_SOURCE=/path/to/project/project_folder/venv/bin/activate, JEDITERM_SOURCE_ARGS=, LC_CTYPE=UTF-8, TERM=xterm-256color, TERMINAL_EMULATOR=JetBrains-JediTerm, TERM_SESSION_ID=a217fa5c-5cc0-4ecd-80e0-1237dadfaf49, ZDOTDIR=/Applications/PyCharm.app/Contents/plugins/terminal/zsh}
2023-07-30 18:19:06,071 [158009271]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;OSCUnlock=f3ce7534-d432-4633-babd-c13a7e19b260BEL
2023-07-30 18:19:06,071 [158009271]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;Dir=/path/to/project/project_folder
2023-07-30 18:19:06,071 [158009271]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;Shell=zshBEL
2023-07-30 18:19:06,072 [158009272]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;ShellPath=/bin/zshBEL
2023-07-30 18:19:06,072 [158009272]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;PID=48355BEL
2023-07-30 18:19:06,072 [158009272]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;ExitCode=0BEL
2023-07-30 18:19:06,072 [158009272]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;TTY=/dev/ttys011BEL
2023-07-30 18:19:06,072 [158009272]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;Log=BEL
2023-07-30 18:19:06,072 [158009272]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;ZshAutosuggestionColor=BEL
2023-07-30 18:19:06,072 [158009272]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;FigAutosuggestionColor=BEL
2023-07-30 18:19:06,072 [158009272]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;User=userBEL
2023-07-30 18:19:06,161 [158009361]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;StartPromptBEL
2023-07-30 18:19:06,161 [158009361]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;EndPromptBEL
2023-07-30 18:19:06,161 [158009361]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;NewCmd=f3ce7534-d432-4633-babd-c13a7e19b260BEL
2023-07-30 18:19:06,161 [158009361]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;StartPromptBEL
2023-07-30 18:19:06,161 [158009361]   WARN - com.jediterm.terminal.emulator.JediEmulator - Error processing OSC: ESC]697;EndPromptBEL
2023-07-30 18:19:11,238 [158014438]   INFO - STDOUT - ------
2023-07-30 18:19:11,238 [158014438]   INFO - STDOUT - unfocus 5
2023-07-30 18:19:12,260 [158015460]   INFO - STDOUT - ------
2023-07-30 18:19:12,260 [158015460]   INFO - STDOUT - focus 5

I attached the log file
Also the VIRTUAL_ENV environment variable is empty

0
Sorry, I would really like to see the full log to get a better picture. Could you please submit a bug report to https://youtrack.jetbrains.com, attach the log there, and ping me here? You can limit the log visibitliy so it's not accessible to public (https://www.jetbrains.com/help/youtrack/standalone/Set-Visibility-of-Issue-or-Comment.html)
0

Here is the link with the full zip with the logs file
Let me know if I mentioned the correct nickname in my request there
https://youtrack.jetbrains.com/issue/PY-62026/Pycharm-after-updating-to-2023.2-the-new-terminal-window-doesnt-activates-the-venv

0

Hey, any updates? I am still having this issue

0

Hey, everything works perfectly.
Andrey showed me how to fix the issue!

0

Can you tell me how to fix it? I can't access the issue above (404 code) :(

0

Certainly!
If you are a Mac user, here is a solution from the Pycharm support team.

Code:

if [ -n "$JEDITERM_SOURCE" ]
then
  source $(echo $JEDITERM_SOURCE)
  unset JEDITERM_SOURCE
fi


1

Thanks! It worked! I wouldn't figure it out myself! 🤝

0

Excellent, have a nice day!

0

Hi, I've been having the same issue, although I'm using Windows and trying to activate conda environment. Any idea if something similar could be done?

0

Arttusaarinen95 That should work. Please consider submitting the bug report to https://youtrack.jetbrains.com with the following data:

  • Logs
  • Screenshot of your terminal settings
  • Location of your conda installation
0

请先登录再写评论。