Git error: "unable to read askpass response" after updating to 2023.2 version of IntelliJ

已回答

After updating to IntelliJ Idea 2023.2, I get this error when I try to access to GitHub enterprise platfform:

 

unable to read askpass response from '/Users/<mac user directory>/Library/Caches/JetBrains/IntelliJIdea2023.2/tmp/intellij-git-askpass-local.sh' could not read Username for 'https://atc-github.azure.cloud.xxx': Device not configured

 

Everything is well configured, I even tried removing and configuring account again, updating git to last version, removing IntelliJ and installing it again, Invalidating caches... but nothing worked.

Finally I had to remove last version and come back to previous version of IntelliJ.

4

Could you try to enable the Use credential helper option in Settings (`⌘ + ,`) > Version Control > Git and invalidate caches (File > Invalidate Caches.. > enable Clear file system cache and Local History option > Invalidate and Restart)?

Does it work when you perform pull/fetch from git bash directly (outside of IDE)?

If the issue persists, please restart IntelliJ, reproduce the issue again and share your IDE logs (Help > Collect Logs and Diagnostic Data)? You can upload them to https://uploads.jetbrains.com, just provide the uploaded file ID.

28

Did not work for me.
Using JetBrains Toolbox I rolled back to version 2023.1.4 and all was fine again.

0

Gorjan Djundev
Could you please file a new issue at: https://youtrack.jetbrains.com/newIssue?project=IDEA
And provide IDE logs (Help > Collect Logs and Diagnostic Data) from 2023.2 version to analyze it further? As it is easier to process such issues in the issue tracker rather than a forum post. Thanks!

0

Hi Ivan Pajic

I had the same problem, but your instructions worked for me. Thanks.

2

@M-gruber

There is an issue open for this: https://youtrack.jetbrains.com/issue/IDEA-326514
Please check it for any possible solution. Especially this workaround: https://youtrack.jetbrains.com/issue/IDEA-326514/unable-to-read-askpass-response-intellij-git-askpass-local.sh#focus=Comments-27-7948918.0-0
It seems it helped lot of users.

2

Hi, Ivan Pajic

after updating to 2023.2 version of IntelliJ, I got the same problem. 

Your solution (File > Invalidate Caches.. > enable Clear file system cache and Local History option > Invalidate and Restart) works for me. Thank you so much!

3

Hi, Ivan Pajic

After upgrading to 2023.2, I fight with this issue for almost the whole day (dive into some other old thread or posts of 2016 with the same error message) until I saw your solution. Thanks for your sharing. 

 

1

My Idea version is 2023.2 and I have the same problem.

I disabled the gitlab plugin and it's back to normal.

2

I have the same issue after updating on 2023.2. Clear file system cache doesn't work for me. The system is Ubuntu 22.04.3 LTS.

UPD: disable GitLab plugin helped

1

This issue will be fixed once the 2023.2.1 is out (it is availabe for Intelij), other IDes will follow soon. 

1

I had the same problem, and Clear file system cache work for me. Thanks. (Build #IU-232.9559.62)

0

Hi Ivan Pajic ,

I tried enable the Use credential helper option

And invalidate caches (Clear file system cache and Local History option > Invalidate and Restart)

It still not works

 

I've uploaded IDE logs (Help > Collect Logs and Diagnostic Data)

File name: idea-logs-20230904-1104088176507555563735306.zip

 

And finally: Disable GitLab plugin works for me +1

Hope that helps!

2

Gene Tso 

I've uploaded IDE logs (Help > Collect Logs and Diagnostic Data)

File name: idea-logs-20230904-1104088176507555563735306.zip

This is the uploaded file name. Could you please provide the uploaded file ID so that we could find it? Thank you.

0

Upload id: 2023_09_04_DfztNfvvrRKTndNHsp1xP1 (file: idea-logs-20230904-1104088176507555563735306.zip)

Thanks

0

Gene Tso 
Yes, it seems it is a known issue: https://youtrack.jetbrains.com/issue/IDEA-326514
As you already worked around it by disabling GitLab plugin - you can vote and follow the original issue for progress updates.
 

2

Hi Ivan Pajic , your Solution is working for me , which was created on Created July 28, 2023 16:09.
Thanks.

1

This is what i have done, On my intellij terminal i just did a git fetch and it asked me for my username and password. I keyed in my credentials and it fixed the error. I think when we key in our credentials, it will cache it. 

0

I had the same issue after upgrading to latest version but thankfully the instruction (https://intellij-support.jetbrains.com/hc/en-us/community/posts/12744271234450/comments/12748042209938)  worked for me. 

IntelliJ IDEA 2023.2.1 (Ultimate Edition)
Build #IU-232.9559.62, built on August 23, 2023
 

1

Hi Ivan Pajic , I met the same problem in IntelliJ IDEA 2023.2.2 (Ultimate Edition) built Sept 4th, and your solution works for me. Thank you so much!!!

1

I had the very same problem in a fresh IntelliJ installation on a new WIndows 11 laptop. After disabling the Gitlab plugin cloning a repository from git works fine.

0

disable gitlab plugin works for me as well

0

Hi,

Roman Uhlig , N Starostin ,

please check: https://youtrack.jetbrains.com/issue/IDEA-326514/unable-to-read-askpass-response-intellij-git-askpass-local.sh and provide feedback is possible. 

This issue should be fixed 2023.2.3, can you please check with Gitlab plugin enabled? 

0

I was getting this in CLion. I just restarted CLion and the problem went away.

0

I have had this issue since I updated to IntelliJ IDEA 2023.2.2 (Community Edition).

Proposed fix 

“Could you try to enable the Use credential helper option in Settings (`⌘ + ,`) > Version Control > Git and invalidate caches (File > Invalidate Caches.. > enable Clear file system cache and Local History option > Invalidate and Restart)?” 

did NOT work for me.

 

Updating to IntelliJ IDEA 2023.3 fixed the issue.

Additionally, many plugins must be updated from within IntelliJ manually to fit this version.

0

Hi all, 

I can confirm that after update to 2023.3 version the issue is not happening.

0

I had the same issue and the solution above resolved the problem. 

0

Hi, I've got the same issue.

PhpStorm 2023.3.4, remote development on Rocky Linux.

Invalidating caches and restarting did not help.

Disabling the gitlab plugin did not help.

0

Hi Axel, can you please contact our support (via help inside IDE) and send the logs, too? 

0

Done. Request #6098357

0

请先登录再写评论。