How to: disable double quote insertion in PlantUML plugin

I searched long and hard for how to disable double-quote insertion in the PlantUML plugin. I tried:

  • Editor -> General -> Smart Keys -> insert pair quote
  • Editor -> General -> Smart Keys -> HTML/CSS -> add quotes for attribute value on typing '=' and attribute completion
  • Editor -> General -> Smart Keys -> JSON -> automatically add quotes to property names when typing ':'
  • Editor -> Code Style -> HTML -> Generated Quote Marks = None
  • Editor -> Code Style -> HTML -> Other -> Generated Quote Marks = None

I finally found that PlantUML has its own separate code completion settings. Open a *.puml file, click on the wrench in the file toolbar and select Open Settings. Find the "insert paired (), [], {}, "" and uncheck it.

Hope this helps someone else not waste an hour on this.


wow, thanks!!!!! Awesome plug-in. Subpar code completion.