Pycharm: Still haven't found solution for Argument for : @NotNull parameter 'module' f com/intellij/openapi/roots/ModuleRootManager.getinstance

Still haven't found solution for:

Argument for @NotNull parameter 'module' of  com/intellij/openapi/roots/ModuleRootManager.getinstance

As you can observe this line refers to a line of java code. There's no way this has to do with any python run parameter?

I can run my scripts when in the run config  I run it in the console, but I can't debug anything (the exact reason I choose to work with an IDE)




Please try creating a new project and check if the issue affects it as well. 

If it works as expected, please try removing the .idea folder from the project root directory. 

If the issue affects newly created project, please copy the full error output and attach it to the thread.

Thanks I did just what you said

1. new project worked fine

2. deleted .idea -> worked 


much obliged


This is not a good solution, I have far to many run configurations etc to just delete them. how do we get JB to fix this bug?

If the issue reoccurs, please archive the faulty .idea folder, upload it here:, and post the upload ID to the thread so we can investigate this issue thoroughly.

Hello. I'm facing the same problem. Everything worked in 2023.2, and having the same message

Argument for @NotNull parameter 'module' of com/intellij/openapi/roots/ModuleRootManager.getInstance must not be nul

since upload to 2023.3 a couple of days ago. 

I tried to delete .idea folder but id not work for me. I also tried with fresh install of pyCharm pro (trial). Same problem. 

I store my run configuration in a .run folder.

EDIT . Il tried to rolling back to 2023.0.5 => same issue. Somethin is broken in my config :(



Ludovic Bernada , can you please provide with .idea folder from the project root directory along with logs from Help | Collect Logs and Diagnostic Data?



Infortunately I can't post my .idea folder. I deleted it too quickly, but I figured out the bug. As said below, my run configurations are saved as xml file in .run folder. With pyCharm 2023.3, I created a fresh run config, with same parameters as old config (2023.2) , and every run fine. After comparing the two generated xml files, it appears that they are pretty different … but with same parameters.



I have had this today and quickly resolved it (pycharm 2023.3.4). 

It seems that any run configuration which has in its xml definition <module name="foo" /> will cause this error unless the project name is really “foo”. By manually editing the xml property to be the name of the project in terms of its pycharm name, this is resolved.

This happened for me after git cloning a project containing run configurations as part of its git managed content: the run configurations carried the project name in their xml definitions, and in my pycharm project made out of the git cloned project, the project name is different ― because pycharm initially uses the name of the directory as the project name by default. 

I cannot see how this can be avoided as long as the project name entity of pycharm is kept in that xml file (which I'd rather it didn't).


I am happy to move this to any existing bug description regarding pycharm project names, as this stands in the way of sharing run configurations.