Clion can't run with error message "entry point not found"


Clion after updating it doesn't open and it gives me "The procedure entry point CreateAppContainerProfile could not be located in the dynamic link library USERENV.dll" I have tried many things and nothing worked i use windows 7

I have tried some commands in command prompt like sfc /scannow but it didn't detect any corrupt files i have also tried DISM and it did not benefit me ,i also tried uninstalling and reinstalling it.



The latest CLion release (2023.2.*) requires a 64-bit version of Windows 10 1809 and later, or Windows Server 2019 and later, as stated in the system requirements on the download page or in the CLion web help.


Actually, what Anna wrote is partially false; the stated requirements are as given, but the actual requirements, at least currently, are Win10+ only for the app runner, and not the app itself, since it's still basically a JVM app which is still Win7-compatible. Run the IDE directly (either from the JAR or via supplied .bat file), and you should be good.