How to get access to manage cursor from IntelliJ IDEA on macOS?


Hello everyone! Can someone please help me? I've encountered the following issue: I need to grant access to IntelliJ IDEA to control the cursor on my Mac Air M1. I understand this might be a bit off-topic, but here's the thing: while working on a study project, I wrote the code for a desktop application called "Text Editor" which has a user interface built with Swing. There's also a test class that, when run, tests both the application's logic and button clicks. When I run the test from IDEA, the cursor doesn't work, but when I run the test class through the console, everything works correctly. How can I grant access to control the cursor?


Your problem might be related to
Do you use the JetBrains Toolbox to start the IntelliJ IDEA? If yes, do you still have this issue if you start the IntelliJ IDEA from the launchpad/spotlight instead of starting it from Toolbox?

Thank you! You saved my life :)

Please start the IDEA from the launchpad/spotlight/dock as a workaround. I have shared your case in the with a private comment to let the developer know this case. Hope we could address this issue soon.