Webstorm deactivate automatic indent for chained methods

Hi. I tried to deactivate automatic indent (when coding) and reformater indent (when pressing CTRL+ALT+L) but I can't make it work.

I disabled option “Indent chained methods” inside “Settings → Editor → Code Style → Typescript → Tabs and Indents”

 

But when I write a chained method, it indents like this automatically (I can force it to stay in the same indentation of the main method, but it's annoying). And this is the result I get when I hit CTRL+ALT+L which is really not what I wanted.

Do you have any suggestion on how to fix this ?

Thank you for your help.

0

Unfortunately I failed to reproduce the issue

Could you share a complete code snippet that reproduces it plus your code style preferences (<IDE config dir>/codestyles/<scheme name>.xml) if you are using IDE-level scheme, or .idea\codeStyles\Project.xml when using a project scheme)?

0

Well after a few restarts, I got it working as intended. I already had this issue 3 times before, but I don't know how to reproduce it. I'll keep this post updated If I find what caused this.

0

The issue looks similar to https://youtrack.jetbrains.com/issue/IDEA-327617/Indents-settings-do-not-work-for-typescript-js-files. Unfortunately the problem is intermittent, and we have been unable to reproduce it on our end. We have introduced some additional diagnostics in 2023.3 EAP. Please could you download it and, if the issue persists, enable the debug logging there? Here are steps:
1 Open Help | Diagnostic Tools | Debug Log Settings...
2 Add the #com.intellij.application.options.codeStyle.cache.CodeStyleCachedValueProvider key there
3 Restart the IDE, reproduce the problem.
4 Choose Help | Collect Logs and Diagnostic Data... from the main menu
5 Share the created .zip file.
 
This would help us a lot in tracking down and fixing the bug
 

0

请先登录再写评论。