Javascript Debugger Broken in Chrome

Not sure what happened but I think Chrome / chromium updated and now the JavaScript debugger is not working anymore.  I typically use Vivaldi (based on Chromium) and it has been working flawlessly for a good 6-9 months but Vivaldi and Chrome updated a day or two ago and now neither of the browsers work.


I tried adding --remote-allow-origins=* for chrome but no luck.

What I am seeing:

  • Loads the browser selected
  • Does not load the URL specified in the configuration settings
  • Then after about 1-2 seconds I get the following error:


  • Webstorm: 2023.2.3 (Build #WS-232.10072.28)
  • Chrome:  119.0.6045.016
  • Vivaldi: 6.4.3160.34
  • Windows 10 PRO 22H2
  • WSL2

* Code is hosted in WSL2 but browsers are located in Windows.


Update on this….

If I click “Try another port…" it loads the browser with the correct URL and seems to work that way.


BUT the default way of just clicking the debug button beside the run configuration selector still does not work.


Another update…

Updated Chrome and closed all chrome windows then tried the normal way and it works again.