Cannot choose interpreter of my choice

So I’ve installed the latest version of Python (3.12) and have updated my PyCharm to the latest one on my Mac. However when trying to select the interpreter, there is no option for Python 3.12. I’ve tried selecting the interpreter by putting in the path but that too throws in errors. (I didn’t have this problem last year when I updated my Python to version 3.11 as it was automatically detected by the interpreter).

Could anyone tell me what am I doing wrong?

0

Hello, 
Unfortunately, the issue is not reproducible for me. 
Could you please take some screenshots of the adding interpreter process and the errors produced? Also, please try running python3.12 --version in the system terminal and check if it produces the correct output.

0

Running the above command in the terminal gives the current version, which for me is python3.12.


I was able to kinda solve the issue by changing the System interpreter settings, which makes the interpreter as python3.12 but has given rise to another issue (which I have written about in another post)

0

请先登录再写评论。